summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto/jwcrypto-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jwcrypto/jwcrypto-0.4.2.ebuild')
-rw-r--r--dev-python/jwcrypto/jwcrypto-0.4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/jwcrypto-0.4.2.ebuild b/dev-python/jwcrypto/jwcrypto-0.4.2.ebuild
new file mode 100644
index 000000000000..5403109a9b1b
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-0.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+
+HOMEPAGE="https://github.com/latchset/jwcrypto"
+SRC_URI="https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-1.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}