summaryrefslogtreecommitdiff
path: root/dev-python/klein/klein-23.12.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/klein/klein-23.12.0-r1.ebuild')
-rw-r--r--dev-python/klein/klein-23.12.0-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/klein/klein-23.12.0-r1.ebuild b/dev-python/klein/klein-23.12.0-r1.ebuild
deleted file mode 100644
index c9b9f089e88f..000000000000
--- a/dev-python/klein/klein-23.12.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Micro-framework for developing production-ready web services with Python"
-HOMEPAGE="
- https://pypi.org/project/klein/
- https://github.com/twisted/klein/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv"
-
-RDEPEND="
- <dev-python/attrs-24[${PYTHON_USEDEP}]
- dev-python/hyperlink[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/tubes[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.6[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/treq[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}