summaryrefslogtreecommitdiff
path: root/dev-python/lazr-config/lazr-config-2.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lazr-config/lazr-config-2.2.3.ebuild')
-rw-r--r--dev-python/lazr-config/lazr-config-2.2.3.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/lazr-config/lazr-config-2.2.3.ebuild b/dev-python/lazr-config/lazr-config-2.2.3.ebuild
index 51ec50017b8e..c6a3980548d9 100644
--- a/dev-python/lazr-config/lazr-config-2.2.3.ebuild
+++ b/dev-python/lazr-config/lazr-config-2.2.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,10 +15,20 @@ HOMEPAGE="https://code.launchpad.net/lazr.config"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
-LICENSE="Apache-2.0"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
+ dev-python/lazr-delegates[${PYTHON_USEDEP}]
+ dev-python/namespace-lazr[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/lazr-delegates[${PYTHON_USEDEP}]"
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}