summaryrefslogtreecommitdiff
path: root/dev-python/libpillowfight
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libpillowfight')
-rw-r--r--dev-python/libpillowfight/Manifest2
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild9
2 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/libpillowfight/Manifest b/dev-python/libpillowfight/Manifest
index 886c441a2fc4..784b797be53a 100644
--- a/dev-python/libpillowfight/Manifest
+++ b/dev-python/libpillowfight/Manifest
@@ -1,3 +1,3 @@
DIST libpillowfight-0.3.0_p20210816.tar.gz 89491019 BLAKE2B 24a658ce461928750582560ef27fbc1ea233bb7c6290053bee7ab3437816fd0e9d7933e36a7a90c75706bdc17024200d16a17ec81c0c30563f043e6d15cc074e SHA512 a731a7d8c8492f5f6229315c8ff48bcdf215acd501d1a5f726f60d6417f77d04b702579d972aaa90f9d01d27b7b167b47f15f435c0fe79598aedb55ac397835b
-EBUILD libpillowfight-0.3.0_p20210816.ebuild 969 BLAKE2B 4ee76bdff48df1d5d84f18adef37698d39f37b42e8f52facbf0a7d7e385509a7feb153e6cb8c983879a48383e646e144baf52d739a2d3812639fc8afa9e0f219 SHA512 6408bc47b9c4efe4efcc087ba7f9a10d093383ac5b51a5fd589e8170dee15ae456ae5f9c5a53c110bac5c480c0d1678f7bb1b9ed4d73bca156eddcb4022aacb6
+EBUILD libpillowfight-0.3.0_p20210816.ebuild 940 BLAKE2B 2a491ccc3291b1302078cfad6ce858af9540d4139a9f33edbed01cf52232cf36ba48a048975129965d41caf67dc40d52c6f8da6cce92229cf983662c81098c51 SHA512 ee7cc25cfa791a8c756afec4448b27750498accde0c6e1fcf46cfce54d08ef24366b639721030ba0adb1ece2c6f509997f4e64f6831fc773c1b2ff965689b858
MISC metadata.xml 339 BLAKE2B eb03aef7b22a30ac1461bf4029711508901ad331209fad7a6a78f0ad3a5cf1902ba963d6d8da569349351f854775a452c1efbace189160111738ee5fb58a2110 SHA512 3978257244b718456e3c9b0f3971626bdd6e927e339c58275c44c19d5098290f9e7c824c53d86306ebeadf58d80bc7089d099e5721e70f36d61bcda16a6c626f
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
index 5e1ace91926e..62e40857072e 100644
--- a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
+++ b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,7 @@ RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
distutils_enable_tests nose
python_prepare_all() {
+ ln -s "${S}"/tests "${T}"/tests || die
sed -e "/'nose>=1.0'/d" -i setup.py || die
cat > src/pillowfight/_version.h <<- EOF || die
#define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
@@ -31,8 +32,6 @@ python_prepare_all() {
}
python_test() {
- cp -r -l -n tests "${BUILD_DIR}/lib" || die
- cd "${BUILD_DIR}/lib" || die
- distutils-r1_python_test
- rm -r tests || die
+ cd "${T}" || die
+ epytest "${S}"/tests -o addopts=
}