summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-10.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit/lit-10.0.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-10.0.0.9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/lit/lit-10.0.0.9999.ebuild b/dev-python/lit/lit-10.0.0.9999.ebuild
index 32320b7920e1..e051ca51410e 100644
--- a/dev-python/lit/lit-10.0.0.9999.ebuild
+++ b/dev-python/lit/lit-10.0.0.9999.ebuild
@@ -4,15 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit distutils-r1 git-r3 multiprocessing
+inherit distutils-r1 llvm.org multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-S=${WORKDIR}/${P}/utils/lit
-
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -29,11 +26,6 @@ BDEPEND="
# TODO: move the manpage generation here (from sys-devel/llvm)
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' utils/lit
-}
-
python_test() {
local -x LIT_PRESERVES_TMP=1
./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \