summaryrefslogtreecommitdiff
path: root/dev-python/locustio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/locustio')
-rw-r--r--dev-python/locustio/Manifest5
-rw-r--r--dev-python/locustio/locustio-0.7.3.ebuild30
-rw-r--r--dev-python/locustio/metadata.xml12
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/locustio/Manifest b/dev-python/locustio/Manifest
new file mode 100644
index 000000000000..203e8127bfc5
--- /dev/null
+++ b/dev-python/locustio/Manifest
@@ -0,0 +1,5 @@
+DIST locustio-0.7.3.tar.gz 89300 SHA256 220e1f97ece2def3454aeecc5070419518e4e16c5aa39d21eb509a38f47847ec SHA512 fe2434691218be0749c0bf7c2c26b6b3172b7dd69898667441aa98a67ac5e5fbb513aebd27bd54c10f423da452f734c2d6ab7a52f4641755439cd3b81a82eee4 WHIRLPOOL f7e485f9bbfbf30dbe9d55c7642dbb10df3616d5f7c11612218adea4113b519a4a0b084f35f32de73181150edddc6e5d7f698eb453462987c727c1d5dc9b0661
+EBUILD locustio-0.7.3.ebuild 747 SHA256 7ace91be4b82d5dae7b2896a76a880ac91cc9e556fb701432c6ef559283fbf96 SHA512 45c7c5ec6e1c2590ac02e93ddf0c217d4c3a82ff4f960294437a25e2546ad1a2b815394f059fb2168b6af074ed8ae9d1a125dca93f7d4a6c51ed21577e965d64 WHIRLPOOL a04b4b5ae2d3dbffd2726f343385ed7623b34dcec96f4a88a5b17ea48801490d14e5fb06f98d57042b5bee3bbd544ea358c36305b2ea0696bd4b9e1ff5150dd1
+MISC ChangeLog 2432 SHA256 45ce2c805985b332dbc06748d50dc6d8dc2dd7881fb1d316b3f77a0a3568a941 SHA512 d8526ecd2dd3dd72286c4744806e830a0976aa6bfe4734637989cee1bba77d0278291ba53bdf7ca695a5125d1b3d49773a7f0b36dfdee4764c554e506e0b6502 WHIRLPOOL 9d94233ef86c35ebee2783ad83ac762d071f0339a6b2f2ac382edea667a9d3a9691681bae7ea5e6e5b4eafb6cfd8def00de7baff3d38f0c63711450f8e8b9f28
+MISC ChangeLog-2015 426 SHA256 d878de2899c3dd39c2570649225e7c27b4e236a73cadb4139a76ed48380b0cdd SHA512 326df274c04e48aea82aac4bf1c5ad70573e4950b9be04134a94dd4548b1a29ee59c039e311c7c88f79e73069145a8fd8fa35e854280a8f4132e7fc61255cdce WHIRLPOOL b992a2ab6b6c7b4b19ef7220c1b3f4e6423c71416640eca3946947cce56d03145796187ee1ac22c62ab31a488ab49edd35031f6fda7ba52a4685cea7e79aeabd
+MISC metadata.xml 375 SHA256 238f978194c0a437774061d20281d1f05b610a5795fa4559005822487cf42920 SHA512 6bd93bd6d77b281cf7ffcc4cfdfceae7247a4461bc619cf5b935841e3befe385cd1c26b5da8bf20e0e551cfed0c73278e82cda16736cc2fae6b5cd69fa0cf805 WHIRLPOOL 60167197269890fa216243c5048b0eba4a3dedf9e16afe9f5b9e7f938848f3ba48d8d90f852bb3ec43f2327403ef4258879224469a178d1ff5a7ff16cc54e301
diff --git a/dev-python/locustio/locustio-0.7.3.ebuild b/dev-python/locustio/locustio-0.7.3.ebuild
new file mode 100644
index 000000000000..7892ab1e586c
--- /dev/null
+++ b/dev-python/locustio/locustio-0.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="A python utility for doing easy, distributed load testing of a web site"
+HOMEPAGE="http://locust.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/gevent-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/locustio/metadata.xml b/dev-python/locustio/metadata.xml
new file mode 100644
index 000000000000..42b654393052
--- /dev/null
+++ b/dev-python/locustio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">locustio</remote-id>
+ <remote-id type="github">locustio/locust</remote-id>
+ </upstream>
+</pkgmetadata>