summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest4
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild59
-rw-r--r--dev-python/loky/loky-3.5.1.ebuild2
3 files changed, 2 insertions, 63 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 5fa89f4571ad..d83957fbaa7a 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,5 +1,3 @@
-DIST loky-3.4.1.gh.tar.gz 143933 BLAKE2B b55dc9fe431769de6bc7f8d9854c40a361566d9c0325c7037255c5ce2b9875ff071743892ec5db53be7744955558195eb40fc5467917eeba3d533c68f285a1ec SHA512 435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06
DIST loky-3.5.1.gh.tar.gz 145759 BLAKE2B 3fd1a254051a25e0556c29c50d9153e6894150d0eb39094fa3b7128439889777026aea6e001b73d825b6c18c8d7e6e49e0feb6e7fb508696c0694cf5321fa6fd SHA512 9c90fda5af45a89142866a3ec4a2e77425b20f248d55a56f5e78acf09dbf3b61ba04cf4b72c416e1eb343e23ab0d73a0139804a9fd92e27044debf97b8920635
-EBUILD loky-3.4.1.ebuild 1799 BLAKE2B 42f3b795390b660e46415a60f12dbac5b8bd189cc1023cf903a62799cb2e61c3baa396fc1ccfe5589765cb0453a847b54e88a2da313c0e29b79386af349f739e SHA512 21e973ed6ad8cb79cae5ff5570e4ed75f38e9580038da225c9d78fbe3a4557250908c266219fb2ff25d25b7ab71a02071ba1fbf1df403ea87871ff5f1b30b9f9
-EBUILD loky-3.5.1.ebuild 1803 BLAKE2B e0c1946ad59e64146442ab2dbf90ba3fd627d7605fbff1b18949f805a7c53f4db4fe12645d1b439610586aea819f69db6ce9f0613bcfe1802afbc9108a84cc57 SHA512 7a9ef00a643a51df901c919c8910c4a80dbe6002818c59fed422ccd3178def2ba876046cc03a1aa9ecf87c6a1ffeb228b23968ce753cc40fd523bb1657fe57f3
+EBUILD loky-3.5.1.ebuild 1799 BLAKE2B d033b11a7d29b06a7ade4909a24143cc4fe5438be8f6999459ac16f95e1464d06ff248a14b64d4b29d8c8af47da5256411756f8105675c257b6af7f9155881de SHA512 9a68236b0ddd2324cf99bd5fbd434fe850aa5d3ef5283e7fd2eef6cf4970782026c9e7594ad6f34c67360330ee134661cef2c44f3183402a64c9fcd427b24253
MISC metadata.xml 383 BLAKE2B 9d990e2f5b4fbf959925d9d7c1f03ecb3acddcc8564c9362f14741d531d79f3e4c6d98a8c84695d8b1f761fa11a80e768b8e8b48ff8be314732d7f574d767223 SHA512 89d9a1f5c253bf99992d16b974d81175d1ae0d17649ffe1a485430735bec38f45e8e1a35c9ba2d99cb1610db3b200adb5af847b2a161c348e29f0cfa89f8076f
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
deleted file mode 100644
index ee013356837d..000000000000
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Robust and reusable Executor for joblib"
-HOMEPAGE="
- https://github.com/joblib/loky/
- https://pypi.org/project/loky/
-"
-SRC_URI="
- https://github.com/joblib/loky/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- EPYTEST_DESELECT=(
- # docker, seriously?
- tests/test_loky_module.py::test_cpu_count_cfs_limit
- tests/test_loky_module.py::test_cpu_count_cgroup_limit
- # hangs, and even pytest-timeout does not help
- tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
- tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
- # Python 3.12 raises an additional warning due to the use of fork()
- # in a multithreaded process, the additional warning breaks this test
- # since the expected warning is no longer the first.
- # This is harmless, skip test for now
- tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
- tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # high memory test needs a lot of memory + is broken on 32-bit platforms
- epytest --skip-high-memory \
- -p xdist -n "$(makeopts_jobs)" --dist=worksteal
-}
diff --git a/dev-python/loky/loky-3.5.1.ebuild b/dev-python/loky/loky-3.5.1.ebuild
index 83c410be5f19..d1ca7bef78f9 100644
--- a/dev-python/loky/loky-3.5.1.ebuild
+++ b/dev-python/loky/loky-3.5.1.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
RDEPEND="
dev-python/cloudpickle[${PYTHON_USEDEP}]