summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest4
-rw-r--r--dev-python/m2crypto/m2crypto-0.43.0.ebuild70
-rw-r--r--dev-python/m2crypto/m2crypto-0.44.0.ebuild2
3 files changed, 2 insertions, 74 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 0504a07a8913..c41e8cf81ab3 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,5 +1,3 @@
-DIST m2crypto-0.43.0.tar.gz 366785 BLAKE2B 611daee57c5605246c0a505604e54ec7e029301194ed75bcb7c02ec04f0246a3dc05e13c8c00f1cc15496495a81c098b203cf69a75ce5a65ea3c7a1c0445e5d3 SHA512 c5232956a88de51bd3a1e02859b7a308eabb4e055cc0c8aac2d8d34a60c60a4a4c7160db4060ec07f559134a04eb41c6ab116a194ec3f7441d342e6d38f9add9
DIST m2crypto-0.44.0.tar.gz 363805 BLAKE2B 0a61574ebee8a82ff2b00fa595870fe8d7e965be893db1e82bd1796703ecec16d7c476185b4b4db754efee1e698f60f20c783d1da04f77ee604afb9a346a2077 SHA512 8f8e9d88852eb003eaad9242ca43a0218354d9af3a6f0d9666ceba0ef2c840cd0aca0ad8493a222eb1de9dd0253c0204dde5530fd6a59ee1c3f29be83ec23458
-EBUILD m2crypto-0.43.0.ebuild 1508 BLAKE2B 4e0e19d5b99df880570c8c5db1949b71e2757ab4cc91bcbbfcdb99df855b40474b7499e55d89d2d1438526044bbaeac6aae6617cd120befa7e854b642d67062d SHA512 47ece67337a050b0ed197b895e783dca50cace3aa6d08d7a8a0bc943a3068cb1cf67c3d07f8987623018b90598300eb7fe38a796bdb127c618a9a9bbbb9118b2
-EBUILD m2crypto-0.44.0.ebuild 1515 BLAKE2B 3b290e33aba805e2bb95109c3489c0353d35ba0918b2001baf37e83c74662037e06092bd02c414a3047de43f9c9580c3c4c95b5dd79f7d417978e1bbc6999244 SHA512 88f20c7e0a5d3b0725b1074487c44dbd683fea96bd46c9657fa3e933275baddf2877d255c11c977960bc90dc3f119bf82bf53cb816898e523bba4ac791c76f28
+EBUILD m2crypto-0.44.0.ebuild 1508 BLAKE2B b2305576235b224db91a69314ab36df142ca6f67fd35995bd1b5fb9c86e33043c74eb520c5cc51526dad54f79521cfaadb2f6c1d6f00b553dc1f574da320c10f SHA512 968d3e9a7f481f7e5cf4d4fbedea8fb3814832fa38d8f3b439dbc0aa83fd301ce108f09d6342acac4c903c72fc9d0a69e8437c2d3f5e414982c087d569aaf265
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.43.0.ebuild b/dev-python/m2crypto/m2crypto-0.43.0.ebuild
deleted file mode 100644
index 89eae437c14f..000000000000
--- a/dev-python/m2crypto/m2crypto-0.43.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2018-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="
- https://gitlab.com/m2crypto/m2crypto/
- https://pypi.org/project/M2Crypto/
-"
-
-# openssl via src/SWIG/_lib11_compat.i
-LICENSE="MIT openssl"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
-
-DEPEND="
- dev-libs/openssl:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-lang/swig-2.0.9
-"
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- distutils-r1_python_compile
-}
-
-python_test() {
- "${EPYTHON}" -m unittest -b -v tests.alltests.suite ||
- die "Tests failed for ${EPYTHON}"
-}
diff --git a/dev-python/m2crypto/m2crypto-0.44.0.ebuild b/dev-python/m2crypto/m2crypto-0.44.0.ebuild
index 0df21271a435..0372786eec89 100644
--- a/dev-python/m2crypto/m2crypto-0.44.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.44.0.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="
# openssl via src/SWIG/_lib11_compat.i
LICENSE="MIT openssl"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
DEPEND="