summaryrefslogtreecommitdiff
path: root/dev-python/markups/markups-3.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markups/markups-3.0.0-r1.ebuild')
-rw-r--r--dev-python/markups/markups-3.0.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/markups/markups-3.0.0-r1.ebuild b/dev-python/markups/markups-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..49bfc95f270e
--- /dev/null
+++ b/dev-python/markups/markups-3.0.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P=${P^}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="
+ https://pymarkups.readthedocs.io/en/latest/
+ https://github.com/retext-project/pymarkups
+ https://pypi.org/project/Markups/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ app-text/pytextile[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+S="${WORKDIR}/${MY_P}"