summaryrefslogtreecommitdiff
path: root/dev-python/matterhook/matterhook-0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matterhook/matterhook-0.1.ebuild')
-rw-r--r--dev-python/matterhook/matterhook-0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/matterhook/matterhook-0.1.ebuild b/dev-python/matterhook/matterhook-0.1.ebuild
new file mode 100644
index 000000000000..36526446b338
--- /dev/null
+++ b/dev-python/matterhook/matterhook-0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"