summaryrefslogtreecommitdiff
path: root/dev-python/matterhook/matterhook-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matterhook/matterhook-0.2.ebuild')
-rw-r--r--dev-python/matterhook/matterhook-0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/matterhook/matterhook-0.2.ebuild b/dev-python/matterhook/matterhook-0.2.ebuild
new file mode 100644
index 000000000000..0a9016cec09b
--- /dev/null
+++ b/dev-python/matterhook/matterhook-0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"