summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.4.2.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index 09ad3875219d..12212cb5c4b0 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,3 +1,5 @@
DIST mdit-py-plugins-0.4.1.gh.tar.gz 63342 BLAKE2B 3db6312e4d36cd7e870a707cbd2b99a4c954e40da2c34711a4b1f1fbd4086231f8e6013c99abdf3dc294acdfdc2706f2353151d2766223e141a0c6aa90e27996 SHA512 d2f5c59bf2a17ce441de18f815624cb6f61202f111176c5f1c7745e430d59e8690ce8a5f9da2402bd34dcc5cf4dc38377990df649fbf3256216bc82cdfc6333a
+DIST mdit-py-plugins-0.4.2.gh.tar.gz 64576 BLAKE2B 30b2594db09c15362c7800a3cf2219d2f1ab1d43678f7fe6a33c699027bea446657708e2ec08a0dc03fe6b644f8a5ac4c02c63cca2738488eff8027faf976f0c SHA512 203a0243968eb9240436c992b70ad0a4b13a747af9ec1799408975cf430d908e8c161cc6810385e21e09eb2d50aeae73f0aed11790898e5d6291b0d4c20521cd
EBUILD mdit-py-plugins-0.4.1.ebuild 760 BLAKE2B bf6cc5ed917b9b38ef178a1ce59cba218c6a4747e7d37a2aab093d1c6339d56059f66c3d071e1a888cf635ef0b6aad13195e9272a677fa7a57669e474731c5b1 SHA512 2d10a5369e755a45cf46ac175654caed7196e489fe9a904e36c5110264f27f32963c1baee75150ab5dd17a80331affb930d3701af37c23a3fa8ced18a544b605
+EBUILD mdit-py-plugins-0.4.2.ebuild 768 BLAKE2B 5fb7618e700ba8f37e1a7e4191b63193049a68e1ca973225c3ac4a7f203066653e1f366e54b4e158fba716ddc3f91603d4b116ea82da84f3fb5ca51b51affe78 SHA512 65816f312b453fb587148d5bbc1dca29915b4498aedaed881f7ec0c639c745caa997407c3a87c9e976c2195233cd02195aeb32da2ef9b7d679505570cfafe502
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.2.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.2.ebuild
new file mode 100644
index 000000000000..e02bf33f47e6
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest