summaryrefslogtreecommitdiff
path: root/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mechanize/mechanize-0.2.5-r1.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.2.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mechanize/mechanize-0.2.5-r1.ebuild b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..34eb574b0ce5
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ https://pypi.org/project/mechanize/"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ # Ignore warnings (https://github.com/jjlee/mechanize/issues/issue/13).
+ # https://github.com/jjlee/mechanize/issues/66
+ "${PYTHON}" -W ignore test.py
+}
+
+python_install_all() {
+ # Fix some paths.
+ sed -e "s:../styles/:styles/:g" -i docs/html/* || die "sed failed"
+ if use doc; then
+ dohtml -r docs/html/ docs/styles
+ fi
+
+ distutils-r1_python_install_all
+}