summaryrefslogtreecommitdiff
path: root/dev-python/mechanize/mechanize-0.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.8.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.8.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.8.ebuild b/dev-python/mechanize/mechanize-0.4.8.ebuild
deleted file mode 100644
index 06b1f532059f..000000000000
--- a/dev-python/mechanize/mechanize-0.4.8.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 pypi
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="https://github.com/python-mechanize/mechanize"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.4.8-python3.11-test-order.patch
-)
-
-python_test() {
- "${EPYTHON}" run_tests.py || die
-}