summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.17.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index f63ca3dbac0f..fa170950c4ac 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,4 +1,6 @@
AUX meson-python-0.16.0-pyproject-metadata-0.8.patch 2372 BLAKE2B 5bd4cde26e7d814699a2757b319817273e6d19ce456d9c9460ae4d2f224fd0fb329fc3bd5e0eaae076039d9224225f02b22592de149b41ec15c71d371b6e949f SHA512 8ddaf35d35966a4f89da4fe123a4985fff296c303a3fbaf7fb849ac4a3f00f72817f5f7e29b0ac2e103ac9163cc2752736fd0a7ebfb86362151653d5a91e4d26
DIST meson-python-0.16.0.gh.tar.gz 74975 BLAKE2B af74d62a4567bc0a7524e815f1bb4ef3ae7290ccea38c00c3b0013f5e7777d6a41c1631b0c1d83fdd930836599752e3bba3c381c137d275103409a986df4e040 SHA512 99ea4304f15e2e13adf031e7c8cacbbc48c0c80f42a81f9d84242b6279ac9c1a13e3f162be5f472a1e498dc7cf3cba6799bf765b3fd441ac10cd87dc0db38678
+DIST meson-python-0.17.0.gh.tar.gz 79243 BLAKE2B f7eb63b1b6575b03d0a8e218b478a557260bd259206517155ba51f32aa3b168d6e999087ece5695c47addb8313227a24243b88d170ce4a1d0fbdef2cdcc492b2 SHA512 ae1466e6f7c6e1d57353be55d9f6dbba6cb532bf6581f8cf03bc2c13f2bd564f4c5ffee561cf1c46293e208da254dc56ec7311b148d2bf507ce5df875b4909de
EBUILD meson-python-0.16.0-r1.ebuild 1182 BLAKE2B 62070e32a181fcef0af7cd0844ee0ba568a0cc25bd40c2028d50998b87b842ff2def46e5f11110b457ba223b8cf2272728feb5277f61dfd5c4ce5984a61c4427 SHA512 560c712ec52bd99c6f9d1f54f88f35e1a030fe6f1fa41a55e98ee8c57fbc96fb281a8ff15e4ecda79ce3f37d4d9fd16092f1b69cd2dbd063fcb14bbcc351d59e
+EBUILD meson-python-0.17.0.ebuild 1480 BLAKE2B ed2af9f9969f84743e3e756edef96e16535f704c63aab4494b8b1572e49b5c0a75fd0c9a87341492b6be6bdd1af0a5aa1355bdf191c15f43f945bfd1192789c2 SHA512 eaf96029f6f32df129d3fd1b2c9944068393ff5a6f51f67fba1ad625bf112d2cf7a314426a6adedc88620740da101ce9516dbae438d19c83754b40b8bfb28444
MISC metadata.xml 357 BLAKE2B c2b5fd8c6ad39e92970a5e6c1db8950b4850660c9a95a84063504ab75e5dd69e3ab844fcef23cb51f33493b7e522a6d26227ff48dd893c92c422badc70f3c962 SHA512 1402ace4da543de7320a1d97f44177593807d5be9f1891d8a53190581877569508c46fe6b4ce63516c7fee2d2165d59d39f44343dde18438570883da3f4ad28c
diff --git a/dev-python/meson-python/meson-python-0.17.0.ebuild b/dev-python/meson-python/meson-python-0.17.0.ebuild
new file mode 100644
index 000000000000..fd9f62165857
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.17.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.7.1[${PYTHON_USEDEP}]
+ >=dev-build/meson-0.63.0
+ !kernel_Darwin? ( dev-util/patchelf )
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# pyproject-metadata: https://github.com/mesonbuild/meson-python/issues/667
+BDEPEND="
+ >=dev-python/cython-0.29.34[${PYTHON_USEDEP}]
+ test? (
+ <dev-python/pyproject-metadata-0.9[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # required by tests/test_sdist.py::test_reproducible
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "The Test Suite" || die
+ git init -q || die
+ git add -A || die
+ git commit -m init -q || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ unset NINJA
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}