summaryrefslogtreecommitdiff
path: root/dev-python/milk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/milk')
-rw-r--r--dev-python/milk/Manifest7
-rw-r--r--dev-python/milk/metadata.xml26
-rw-r--r--dev-python/milk/milk-0.5.1.ebuild22
-rw-r--r--dev-python/milk/milk-0.5.3.ebuild22
-rw-r--r--dev-python/milk/milk-0.6.1.ebuild22
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/milk/Manifest b/dev-python/milk/Manifest
new file mode 100644
index 000000000000..400a868c55f7
--- /dev/null
+++ b/dev-python/milk/Manifest
@@ -0,0 +1,7 @@
+DIST milk-0.5.1.tar.gz 623685 BLAKE2B f772abb75449e4fcac6fc2437d360a5fa8db4ac3007d5e7eadae1b92b78b639f0b2fd8b26469aa112dca35efd52ba9bab1220c7e3f41dad059624cb15afdce04 SHA512 3ac6811f4c15b65de87cae0089ce3fd8372d4b349ea9b7e49db581dcd29e27baf6e33ddca9c6d96e832ebe499e9032de253da532d3241fbbaa4ac124d97a8386
+DIST milk-0.5.3.tar.gz 620091 BLAKE2B f88c1f6a89ec126dea34cf48d4c8a1eabea3e762ac0650b0ac5f1098c487ce7cd9c0269d61ae8d6862dbb779eacf38dfd862302d877e8f086e0f58770a4c623f SHA512 4b685f682229194d03fc9e6031d5e40890aac793ae87bf7c010f866c032ec53205c281ead7db654f1e4bef30a4e68ef325b560b78fe1b0db00344392d60ef4e4
+DIST milk-0.6.1.tar.gz 628357 BLAKE2B ea781b87aed1ed2b20d8eea16efe3cfc1e9777144e8847ea8617f2de3ee523cc3a9dbb54879206e146924487a10d41302e01d6fa78c812c8c5523b360cdd1e5c SHA512 54a94bc1bf760320b53b2f65396e117bdccd0d4d5e6bdb4684b68d96f3cb3beaf3cc9b285d3ba91b1f97ba335750591c1fb2d2115468ec617dbd1cc65fed9f8f
+EBUILD milk-0.5.1.ebuild 537 BLAKE2B b262f26bd6724d4333fde2fb6d3d2d2bea1f43f761f015dd0e7cd7a0f2a47fe759485682e16118d028e2d43d0f76bcdb2c1a8c3fee709af46921d4d4b0eb84e6 SHA512 96e27b740b2804ead27641a82c80156b23cda409376ab637b5bd4c280a2459eb4bba8629bc9c685e59b2f3c9a9844b4139c96bb7856cf88c092564ed1e1f7a36
+EBUILD milk-0.5.3.ebuild 573 BLAKE2B a57f85f4ce95bacfe14ae217ce3a8c8a02733439aa7ecbdcd4301967a6f4ce46d9f227af1f452ed058c538cf11a8d1017894f0c51a87c47e12300b2272e4708b SHA512 acfdba9177cf09fdb1d29ab6c9b4c41b8913e5e0e1aee6eb2731fdc3cbaa0754ee3181d1817a9c5fa58db95038e6a7a3f422643297bcd417e55b0601a9928d15
+EBUILD milk-0.6.1.ebuild 573 BLAKE2B a57f85f4ce95bacfe14ae217ce3a8c8a02733439aa7ecbdcd4301967a6f4ce46d9f227af1f452ed058c538cf11a8d1017894f0c51a87c47e12300b2272e4708b SHA512 acfdba9177cf09fdb1d29ab6c9b4c41b8913e5e0e1aee6eb2731fdc3cbaa0754ee3181d1817a9c5fa58db95038e6a7a3f422643297bcd417e55b0601a9928d15
+MISC metadata.xml 1152 BLAKE2B b772ced54839c36c070780303aee01a876af081e17883e97176e422c447e5da8878fe0a19fbce00267bfbdbc01ccdfd91472763a6a6c87e492bd41b094c62b49 SHA512 c4d9d5d7774abd15d165107798995a5fe4de13ba96342fbc1c8987876df7133846ca94383942812945e6bea62c9bf8f34073bf264842e58a3e70d181273c640f
diff --git a/dev-python/milk/metadata.xml b/dev-python/milk/metadata.xml
new file mode 100644
index 000000000000..320bb4cda904
--- /dev/null
+++ b/dev-python/milk/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ Milk is a machine learning toolkit in Python.
+ Its focus is on supervised classification with several classifiers
+ available: SVMs (based on libsvm), k-NN, random forests, decision
+ trees. It also performs feature selection. These classifiers can be
+ combined in many ways to form different classification systems.
+ For unsupervised learning, milk supports k-means clustering and
+ affinity propagation.
+ Milk is flexible about its inputs. It optimised for numpy arrays, but
+ can often handle anything (for example, for SVMs, you can use any
+ dataype and any kernel and it does the right thing).
+ There is a strong emphasis on speed and low memory usage. Therefore,
+ most of the performance sensitive code is in C++. This is behind
+ Python-based interfaces for convenience.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">milk</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/milk/milk-0.5.1.ebuild b/dev-python/milk/milk-0.5.1.ebuild
new file mode 100644
index 000000000000..9ad5774bc8f9
--- /dev/null
+++ b/dev-python/milk/milk-0.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Machine learning toolkit in Python"
+HOMEPAGE="http://luispedro.org/software/milk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ dev-cpp/eigen:3
+ test? ( dev-python/milksets sci-libs/scipy[${PYTHON_USEDEP}] )"
diff --git a/dev-python/milk/milk-0.5.3.ebuild b/dev-python/milk/milk-0.5.3.ebuild
new file mode 100644
index 000000000000..3a6fd0fc243d
--- /dev/null
+++ b/dev-python/milk/milk-0.5.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Machine learning toolkit in Python"
+HOMEPAGE="http://luispedro.org/software/milk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ test? ( dev-python/milksets sci-libs/scipy[${PYTHON_USEDEP}] )"
diff --git a/dev-python/milk/milk-0.6.1.ebuild b/dev-python/milk/milk-0.6.1.ebuild
new file mode 100644
index 000000000000..3a6fd0fc243d
--- /dev/null
+++ b/dev-python/milk/milk-0.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Machine learning toolkit in Python"
+HOMEPAGE="http://luispedro.org/software/milk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ test? ( dev-python/milksets sci-libs/scipy[${PYTHON_USEDEP}] )"