summaryrefslogtreecommitdiff
path: root/dev-python/minikanren/minikanren-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/minikanren/minikanren-1.0.3.ebuild')
-rw-r--r--dev-python/minikanren/minikanren-1.0.3.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/minikanren/minikanren-1.0.3.ebuild b/dev-python/minikanren/minikanren-1.0.3.ebuild
deleted file mode 100644
index 2b40697f8079..000000000000
--- a/dev-python/minikanren/minikanren-1.0.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Relational programming in Python"
-HOMEPAGE="
- https://pypi.org/project/miniKanren/
- https://github.com/pythological/kanren/
-"
-SRC_URI="
- https://github.com/pythological/kanren/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/kanren-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/multipledispatch[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest