summaryrefslogtreecommitdiff
path: root/dev-python/mistune/mistune-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mistune/mistune-2.0.0.ebuild')
-rw-r--r--dev-python/mistune/mistune-2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-2.0.0.ebuild b/dev-python/mistune/mistune-2.0.0.ebuild
new file mode 100644
index 000000000000..ca582a8ab68a
--- /dev/null
+++ b/dev-python/mistune/mistune-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # seriously?
+ echo 'build-backend = "setuptools.build_meta"' >> pyproject.toml || die
+ distutils-r1_src_prepare
+}