summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-revision-date-localized-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs-git-revision-date-localized-plugin')
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.4.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
index e3c70cdab259..8e92a68f19b2 100644
--- a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-revision-date-localized-plugin-1.3.0.gh.tar.gz 378511 BLAKE2B e922d0ce5dd37f92c11a37d7c02a59fc776a1a4245823a2275c600c6348cc7f97a2a8b43919a5cdbe03e8b23623f0c7d22cf92eb728d6f11d7472db5b78e98a1 SHA512 6e6c085ae861382a932817264c00de55f94b8b09349c18206c1644487a7476d4494f0b451b31510de4ba3a5d4934514923521c8c4c5aca84a8183f5cd574177d
+DIST mkdocs-git-revision-date-localized-plugin-1.4.0.gh.tar.gz 383048 BLAKE2B 7e7b2fadb1b03409ad81c8a4d70e3a84e41a0b616f10d9ccb0eeed43e31e762478de5a598e5b1afa3466659fe60e9687b9fd2c5ad4ebd2ff3dc42e8d7005a66f SHA512 18d9e59d38cb54ea1aa8fef53d5dcf6cf680d209ad45fa66b0355a5691cf93a63affdccc9a4a5f07223e7d7bde1ed751e985a42f628acdf6d6a4cd8c0947a1a9
EBUILD mkdocs-git-revision-date-localized-plugin-1.3.0.ebuild 1614 BLAKE2B ac2edabf71a4df56aa21c31ce9294185b53e3c4be71ba5c3020d8b0216aeedfa7edf8d75dc8830b34b7898f1cfc36fb8b517c8ddadfd0cfa5cd049b8ad69c1b9 SHA512 1f48dd5fa74e777fa709d21627265aa105197a96728dec41c838b88a00db487f729b9699ec31d568c429a112690149a01da9860b5cb21d3f5e4a094b78e034e7
+EBUILD mkdocs-git-revision-date-localized-plugin-1.4.0.ebuild 1617 BLAKE2B b4934a1d05e1a9488516e079478406ed76d2d13e2b7e136467cba470ae5605d302d1bbdb45af92c70c93605553396f07c664e93ddc676de3b3b2e551138ef4ae SHA512 7bb1a68f828a6ba37b041b68905860c081e9d3214d752108d5af3db78eec894514cf0847a2cd458b376c3096b24dabe340bcbfaecec6b913db4d12a341e053e6
MISC metadata.xml 583 BLAKE2B 720ea91bb3441b2ba2ea4b60d25ba85dbe166ce8d399cc62819be3bcc9e12b8759c1953f949500af7e9c85e4360342819ee045865c76fde45a064308213ae14d SHA512 2e316b0dbc3b7c20b59f4b7c52a8e53c7a4ecba51b33eee53e0fbc627090a394c923e73f6b5fc6cf0bf2b942365f2fa0fa1ee6dc0f54ffe3ded96a580307df28
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.4.0.ebuild b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.4.0.ebuild
new file mode 100644
index 000000000000..b3a2ba3eb129
--- /dev/null
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..13} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-static-i18n
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+ dev-python/mkdocs-git-revision-date-localized-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Display the localized date of the last git modification of a markdown file"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-revision-date-localized-plugin/
+ https://pypi.org/project/mkdocs-git-revision-date-localized-plugin/
+"
+SRC_URI="
+ https://github.com/timvink/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/babel-2.7.0[${PYTHON_USEDEP}]
+ dev-python/gitpython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-static-i18n[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin's tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}