summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-5.0.22.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 06115535df65..a33aa17275ca 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,7 +1,9 @@
DIST moto-4.2.14.tar.gz 4933741 BLAKE2B 4c50a808dc8f27cfbcd0ba234d268084ee9a32f36cb5d6af61aacc4ee79f7bf5cf1045147c4642472129eee37bef8bc2c1953d140260d39d7f333ae0f5e5cf95 SHA512 d4079118ed1d2eef9134575e33dc0ed749bff0293d753baa63a630dbb987914b9933445027abdc344bb93fa1d6e483baf8a337a444c9dd055dda50b095ff9937
DIST moto-5.0.20.tar.gz 6203061 BLAKE2B 0e2126c72eb7a0afbe5ef29251527e7e4822d125e7e107217e6a702e2c51aa274f7181cdd6dd1b0c724315f89e58415e1e89fdb96db6777fac79a85bc0f53421 SHA512 d7a2c4311cc0518761226d200c8691fa70871b779f5f01cf573e0f92e4677a6f9ab5b77b2005b36346b199f3f0f2921df9879d13b1bed95c363537b01a9ef47e
DIST moto-5.0.21.tar.gz 6212667 BLAKE2B 6f1d991214ab4cfacab76db68a5a5b143adf6de226c0bda2b1c48e0d4f3cbd470b83419edf14cb46dbd35ae6f5129db305a4b07b20e9b2da6f746823939b35ca SHA512 a881426643ab1b3fa858bc8effa1816195ea907352aeb96e9a457a3108d8e712f77788f1e7476822484a3a829d68ba1d9f18a3dc990bc9e403b1c049f892064a
+DIST moto-5.0.22.tar.gz 6303034 BLAKE2B 6607f14c2246a63c289ee0ab6b4168a5446e46a9616f680fc2f1ece70a413d0e31d3e078a108556e723e5b4b08657161e1e2224bc602ca60d6c5e935f37af50c SHA512 3f5dcf4f514e7c0864b9a29b26f795505d4604a26c4e062fab4f0414c7a8e009542957ca3c3c6e763e6bccdbd22b74791f3a01f6a52b87a155fe804efeaf9167
EBUILD moto-4.2.14.ebuild 6507 BLAKE2B 4b1e22f10011ddf1b62996ad7d2efb5181843f958705ce1816f223bc3892f8515429f37c24403b03774c72f7d334a544e5688818e0e31f527b39c12979628ecc SHA512 ad9705a1f4c495c7fc9cec848d97a8f0f4d39d81848cb9c6d56788c083aabf120d4c89e8d59518fac93bcdee8561ce1fe8eff89eb277cb29921285899dd2ed97
EBUILD moto-5.0.20.ebuild 5283 BLAKE2B dba3f9a538e58a36c8d8b12d8bca8d7ab9fdc192f84185a7cfc59f369cbc754a1df1bea3659bdc23a9e54f343ce5c791ab8d02fc6819d2aab221745383117759 SHA512 36dc240c79315f75c505be552c9d3bd81190c10f558de3cc9a6f83a4b974414302ccde2eebf49df9585049a1f7641a1162016d76136a956534dae74005281256
EBUILD moto-5.0.21.ebuild 5286 BLAKE2B 061c43d93eef821e5d7942532a9032689f192396a6dd47c2a0b812f0573f2a92890f5b52a87441c066f6d16dbecdfcfc8b35e4d055a2f0d1630c2b44b64403fa SHA512 90e383a2c1fe195cd34fdf4821d69997d0c435fc7dc3d65dde018362d5e0ee0b133514046bc0037fca909762683783f20f807b80eed0b693c65837a33c71957a
+EBUILD moto-5.0.22.ebuild 5286 BLAKE2B 061c43d93eef821e5d7942532a9032689f192396a6dd47c2a0b812f0573f2a92890f5b52a87441c066f6d16dbecdfcfc8b35e4d055a2f0d1630c2b44b64403fa SHA512 90e383a2c1fe195cd34fdf4821d69997d0c435fc7dc3d65dde018362d5e0ee0b133514046bc0037fca909762683783f20f807b80eed0b693c65837a33c71957a
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-5.0.22.ebuild b/dev-python/moto/moto-5.0.22.ebuild
new file mode 100644
index 000000000000..6b7e14c1d8c7
--- /dev/null
+++ b/dev-python/moto/moto-5.0.22.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi toolchain-funcs
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/jsonpath-ng[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.0[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/sshpubkeys[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/antlr4-python3-runtime[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+: "${EPYTEST_TIMEOUT:=180}"
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_core/test_request_passthrough.py
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_aws_and_http_requests
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_http_requests
+ # broken code? (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # require joserfc
+ tests/test_apigateway/test_apigateway.py::test_update_authorizer_configuration
+ tests/test_apigateway/test_apigateway.py::test_create_authorizer
+ tests/test_apigateway/test_apigateway.py::test_delete_authorizer
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserDeleter::test_authenticate_with_signed_out_user
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_email_is_
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_username_
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_different_seed
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_same_seed
+ tests/test_cognitoidp/test_server.py::test_sign_up_user_without_authentication
+ tests/test_cognitoidp/test_server.py::test_admin_create_user_without_authentication
+ tests/test_cognitoidp/test_server.py::test_associate_software_token
+ # TODO
+ tests/test_dynamodb/test_dynamodb_import_table.py
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_stepfunctions/parser/test_stepfunctions_dynamodb_integration.py::test_zero_retry
+ # random crashes
+ tests/test_stepfunctions/parser/test_stepfunctions_sns_integration.py
+ tests/test_stepfunctions/parser/test_stepfunctions_sqs_integration.py
+ tests/test_stepfunctions/test_stepfunctions.py
+ )
+ local EPYTEST_IGNORE=(
+ # require joserfc
+ tests/test_cognitoidp/test_cognitoidp.py
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # suddenly started crashing, *shrug*
+ tests/test_xray/test_xray_client.py::test_xray_context_patched
+ tests/test_xray/test_xray_client.py::test_xray_dynamo_request_id
+ tests/test_xray/test_xray_client.py::test_xray_dynamo_request_id_with_context_mgr
+ tests/test_xray/test_xray_client.py::test_xray_udp_emitter_patched
+ )
+ ;;
+ esac
+
+ if ! tc-has-64bit-time_t; then
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_acm/test_acm.py::test_request_certificate_with_optional_arguments
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ tests/test_s3/test_server.py::test_s3_server_post_cors_multiple_origins
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_route53domains/test_route53domains_domain.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+
+ rm -rf moto || die
+ epytest -m 'not network and not requires_docker' \
+ -p rerunfailures --reruns=5
+}