summaryrefslogtreecommitdiff
path: root/dev-python/moviepy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/moviepy')
-rw-r--r--dev-python/moviepy/Manifest4
-rw-r--r--dev-python/moviepy/moviepy-0.2.2.ebuild4
-rw-r--r--dev-python/moviepy/moviepy-1.0.1.ebuild35
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/moviepy/Manifest b/dev-python/moviepy/Manifest
index c6d7c7d079e5..dcfb6c5b5203 100644
--- a/dev-python/moviepy/Manifest
+++ b/dev-python/moviepy/Manifest
@@ -1,3 +1,5 @@
DIST moviepy-0.2.2.tar.gz 400489 BLAKE2B 46cbf9fa6b2800dfa7c315c572448c7ba12ab4629dc5d57590ed70d40d83acabe1b140c193f04c990bbe79aa6ac5e7a6ec662e5862e01ccf41c80ce7f159bdc0 SHA512 a4300b31552e8b4120448b8973ce812579b4f38be48fb46546f4a33e9c10903fb73a89c8075d161d441ecf084b3936ef7d6f0d1b637ad347d00db2c643f1cc43
-EBUILD moviepy-0.2.2.ebuild 925 BLAKE2B e717022ca5228689de220f2ab24edd5cfae0deb3ed0d9fddf85b4f71442da3959b7e1ae782ec9ecc3fe1e7dc552e2acda637a67d3bd63cf333c2c5f9e6b6f8df SHA512 4e2056f01c1399860b7b718e40d508e73d500a0825a7a8b5251ba0829011312bf7b38217856daad495d1fd90db14141c1cccda9dec6c6468f732f186a8ca2018
+DIST moviepy-1.0.1.tar.gz 25746520 BLAKE2B 5e18841596e967a1531eef5d7cef8f96a636486923a874606c453bfda92d8ca8657afef9eb46c2b4b3bf7ae58d138866d7497cd088509d403dd6722fca8e8ec5 SHA512 3cdccaa13dd31529a17d480fcd01b5f89b421eeb618425e9fa9a114159d65aac979022507c3f9c64921af60e4c9d7970e6a3223d7942c08e67d7e696618e9abb
+EBUILD moviepy-0.2.2.ebuild 915 BLAKE2B 37c909997d14c545d27743972cd9d4ba47e9d1ae8f579a290495dd57e67c6906055d205390f1230041ed6992316dd555442a8ac59cdd3d93c4c208796827b8c2 SHA512 7991657c741b3f60f287f25dabde0bdeeec09b12c6d490fe3914f0896dd8dc947185e782e761452bf7417326c1374ed30120856d46bb771cec0915acaa90e18a
+EBUILD moviepy-1.0.1.ebuild 874 BLAKE2B a9da61121d29d29bdcd676a25f4792d145cf32b3d1b4c3b0d326a313242866daf5ae9b05bd90936774b26e2966fb12791e0382d3b5c4a2b3794fe648ce4d1626 SHA512 504934a5b91ea0d760e3720a1e286d79ee2bb2dcb36e7d49e7c3148963508287552484c33de6b3f34dbbfeba6b5acc54291957e19c53680b671e29d1d58d0b3f
MISC metadata.xml 732 BLAKE2B 7366dd5078337dd825a1612310d068dc3be9ab38c6a9741038fe4af3ba60a19420d67e6bb5a24c0548a6e9bf8cdf257147735d16a5fb1d2195099e079f1d1d3d SHA512 46bce08e60a3a53dcdd6a6fad0ba31c3d11b5c7a4995ac830a31a1e7f0d2ccf458d1c9d1e45ebf80365675cec5d313a6cc58c9b6ce7083daa14483f2832fa630
diff --git a/dev-python/moviepy/moviepy-0.2.2.ebuild b/dev-python/moviepy/moviepy-0.2.2.ebuild
index 946fe30ab119..068a65775a44 100644
--- a/dev-python/moviepy/moviepy-0.2.2.ebuild
+++ b/dev-python/moviepy/moviepy-0.2.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
diff --git a/dev-python/moviepy/moviepy-1.0.1.ebuild b/dev-python/moviepy/moviepy-1.0.1.ebuild
new file mode 100644
index 000000000000..41b2da26b5c7
--- /dev/null
+++ b/dev-python/moviepy/moviepy-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Video editing with Python"
+HOMEPAGE="http://zulko.github.io/moviepy/"
+SRC_URI="https://github.com/Zulko/moviepy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest