summaryrefslogtreecommitdiff
path: root/dev-python/mpmath/mpmath-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpmath/mpmath-1.3.0.ebuild')
-rw-r--r--dev-python/mpmath/mpmath-1.3.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/mpmath/mpmath-1.3.0.ebuild b/dev-python/mpmath/mpmath-1.3.0.ebuild
deleted file mode 100644
index d03409f5dfaa..000000000000
--- a/dev-python/mpmath/mpmath-1.3.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi virtualx
-
-DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="
- https://mpmath.org/
- https://github.com/mpmath/mpmath/
- https://pypi.org/project/mpmath/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="gmp matplotlib"
-
-RDEPEND="
- gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
-}