summaryrefslogtreecommitdiff
path: root/dev-python/munkres/munkres-1.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/munkres/munkres-1.0.12.ebuild')
-rw-r--r--dev-python/munkres/munkres-1.0.12.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/munkres/munkres-1.0.12.ebuild b/dev-python/munkres/munkres-1.0.12.ebuild
new file mode 100644
index 000000000000..7180da29b0dd
--- /dev/null
+++ b/dev-python/munkres/munkres-1.0.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="https://pypi.org/project/munkres/"
+SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ "${PYTHON}" ${PN}.py || die
+}