summaryrefslogtreecommitdiff
path: root/dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild')
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild
deleted file mode 100644
index 0c7f5c8eefd0..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-2.1.7.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt docs/README_DOCS.txt )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX%/}/usr" --unix-socket="${T}"
-}
-
-python_install_all(){
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}