summaryrefslogtreecommitdiff
path: root/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild')
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild
new file mode 100644
index 000000000000..34ac5df3aa48
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="ZPL"
+SLOT="0"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme