summaryrefslogtreecommitdiff
path: root/dev-python/nbclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest5
-rw-r--r--dev-python/nbclient/files/nbclient-0.10.0-py313.patch35
-rw-r--r--dev-python/nbclient/nbclient-0.10.1.ebuild58
-rw-r--r--dev-python/nbclient/nbclient-0.10.2.ebuild4
4 files changed, 3 insertions, 99 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 0d9b6006c94e..f64999528569 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,6 +1,3 @@
-AUX nbclient-0.10.0-py313.patch 1379 BLAKE2B 3dc2b408b3343b0200244ac33691857347f5fbfcb4543bb25077c4d353e06ec4050439ee45ae8582b62da2805aeba1aeaf4c3dca5b0a4011c78bc30f646150d7 SHA512 08d20f2366229fc44e0fc4356c49e61b45ba075d293606d6eec4a4d1f9a6da4876f6f300d6279969432810fdae97c1491682eef8f6d96d030299e1278148d599
-DIST nbclient-0.10.1.tar.gz 62273 BLAKE2B 0a268e4078af3807b6795d5b6dbbc572628d891d42f4ddeed3decd06d471cad59ab903e652be6a7f1e00a07cea3745cd989c62674e937934a6a696dfd24eefa4 SHA512 8c5b52aa367f255669fa7ad248d45292dd0e3589e23e381027a093c9fc57280eb296f453c2bfc3c57969056846a0caba81e57feaad1768e70aff006df4b85324
DIST nbclient-0.10.2.tar.gz 62424 BLAKE2B f0efae4b3eed70f04f3d0cc830ef4cc47ed98b93785c6048103b62aff9537eaeebc0ad54a513c142c3d76c64d093c9bac3003608c6510b719d9b5de7b67ad463 SHA512 e19e58950822711af8588fdb7a24c1df028c77c2e128023494335973ff28f524478637c491b16329c38edb2ff7714632d4216e6483bb9aa79e2b393e3de72be8
-EBUILD nbclient-0.10.1.ebuild 1490 BLAKE2B 08e58ed6c6210411bb949c6d2f85df6a8d6fa0634b17b032daa269a8d1c2795e0eea228d749709b753ecd9456bab30d1ea1ef797b118c984ede1c0cc6753ac10 SHA512 718c5bb7ac6fc89bb5b6eddfb137a640d35684228c803a36a8d75aa6895297cc9900570ec02a5e02b48860b63b9099322d96750f5de6b5ff155db931e266569a
-EBUILD nbclient-0.10.2.ebuild 1404 BLAKE2B 71c4fc6c24877c22746d2ca595cf8ea1fd814598cb2c97dce34bef7bc4e3407d9483d6adc162bd02c7c1df3e89f4c8bd2462f04d0f7d956fe92a628af15a355e SHA512 f3fbd98f1ae7bd1c1af2c15437e0d781b7630a71c46d198e2ac144a44126fd1e5fa5aa5a17008fc960f0c90e51c0e7b11d0706ba1003ad3f0a58be93a2cd5e9c
+EBUILD nbclient-0.10.2.ebuild 1397 BLAKE2B 64fcf74fd2d8a38b1d601de928c0cead03d24c38b750d141689b185411e09f6e4a49c3c30b05cb57dcc0af4b4d26f3057d77c740cb9c02a739db5a71e586de5d SHA512 ba56905a989e5b5157fa639bc7ce75be76068a57571fac0dcc9527de4c38473b7b06a1858946d83cc25bcdc2d5d093a73e179a8d9299119fc8b6b65e8dc47f10
MISC metadata.xml 405 BLAKE2B d1efa5f7bb2a959bdbc6093b1bd3930e6cdb9bffbe872c6775c15dfc1024ae24d6bcb4651c8e1fb06242b17d6a86f683de3b528bbf1a60b5656a90c1f4ac81b7 SHA512 5b0de690d37dd5928e3bfd0b380336d154cced094e342b41dfd16d0caddd2b792a2158b209404a36461cf4d1b12d836024eae2aedf15093b90f4e363382b38bf
diff --git a/dev-python/nbclient/files/nbclient-0.10.0-py313.patch b/dev-python/nbclient/files/nbclient-0.10.0-py313.patch
deleted file mode 100644
index 1403cd0e0513..000000000000
--- a/dev-python/nbclient/files/nbclient-0.10.0-py313.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 57222265bfd8bdcf8851997e1dce5cd564e1a573 Mon Sep 17 00:00:00 2001
-From: Lumir Balhar <lbalhar@redhat.com>
-Date: Wed, 3 Jul 2024 14:21:41 +0200
-Subject: [PATCH] Fix compatibility with Python 3.13 beta 2
-
-There are more calls in 3.13 than in previous versions
-so the tests are now more permissive.
-
-Fixes: https://github.com/jupyter/nbclient/issues/316
----
- tests/test_cli.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_cli.py b/tests/test_cli.py
-index 04b9887..55ccbd6 100644
---- a/tests/test_cli.py
-+++ b/tests/test_cli.py
-@@ -60,7 +60,7 @@ def test_mult(input_names, relative, inplace, jupyterapp, client, reader, writer
- # add suffix if needed
- paths = [p.with_suffix(".ipynb") for p in paths]
-
-- assert path_open.mock_calls[::3] == [call(p) for p in paths]
-+ assert all(call(p) in path_open.mock_calls for p in paths)
- assert reader.call_count == len(paths)
- # assert reader.mock_calls == [call(p, as_version=4) for p in paths]
-
-@@ -114,7 +114,7 @@ def test_output(input_names, relative, output_base, jupyterapp, client, reader,
- # add suffix if needed
- paths = [p.with_suffix(".ipynb") for p in paths]
-
-- assert path_open.mock_calls[::3] == [call(p) for p in paths]
-+ assert all(call(p) in path_open.mock_calls for p in paths)
- assert reader.call_count == len(paths)
-
- expected = []
diff --git a/dev-python/nbclient/nbclient-0.10.1.ebuild b/dev-python/nbclient/nbclient-0.10.1.ebuild
deleted file mode 100644
index 33919d855b04..000000000000
--- a/dev-python/nbclient/nbclient-0.10.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A client library for executing Jupyter notebooks"
-HOMEPAGE="
- https://nbclient.readthedocs.io/en/latest/
- https://github.com/jupyter/nbclient/
- https://pypi.org/project/nbclient/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/jupyter/nbclient/pull/317
- "${FILESDIR}/${PN}-0.10.0-py313.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # hangs?
- 'tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p rerunfailures --reruns=3
-}
diff --git a/dev-python/nbclient/nbclient-0.10.2.ebuild b/dev-python/nbclient/nbclient-0.10.2.ebuild
index ffd15a47301b..f134d7b6d8a3 100644
--- a/dev-python/nbclient/nbclient-0.10.2.ebuild
+++ b/dev-python/nbclient/nbclient-0.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2024 Gentoo Authors
+# Copyright 2020-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]