summaryrefslogtreecommitdiff
path: root/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch')
-rw-r--r--dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch b/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
deleted file mode 100644
index ff450f2ce447..000000000000
--- a/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/setupbase.py
-+++ b/setupbase.py
-@@ -129,17 +129,6 @@
- build_py.finalize_options()
-
-
--class bdist_egg_disabled(bdist_egg):
-- """Disabled version of bdist_egg
--
-- Prevents setup.py install performing setuptools' default easy_install,
-- which it should never ever do.
-- """
-- def run(self):
-- sys.exit("Aborting implicit building of eggs. Use `pip install .` "
-- " to install from source.")
--
--
- def create_cmdclass(prerelease_cmd=None, package_data_spec=None,
- data_files_spec=None):
- """Create a command class with the given optional prerelease class.
-@@ -179,14 +168,9 @@
- wrapper = functools.partial(_wrap_command, wrapped)
- handle_files = _get_file_handler(package_data_spec, data_files_spec)
-
-- if 'bdist_egg' in sys.argv:
-- egg = wrapper(bdist_egg, strict=True)
-- else:
-- egg = bdist_egg_disabled
--
- cmdclass = dict(
- build_py=wrapper(build_py, strict=is_repo),
-- bdist_egg=egg,
-+ bdist_egg=wrapper(bdist_egg, strict=True),
- sdist=wrapper(sdist, strict=True),
- handle_files=handle_files,
- )