summaryrefslogtreecommitdiff
path: root/dev-python/neovim-remote/neovim-remote-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-9999.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
index 15b4a3d9ac79..a7036334d63e 100644
--- a/dev-python/neovim-remote/neovim-remote-9999.ebuild
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -1,21 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
else
- SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
KEYWORDS="~amd64 ~arm"
fi
DESCRIPTION="A tool that helps control neovim processes"
-HOMEPAGE="https://github.com/mhinz/neovim-remote"
+HOMEPAGE="
+ https://github.com/mhinz/neovim-remote/
+ https://pypi.org/project/neovim-remote/
+"
LICENSE="MIT"
SLOT="0"
@@ -25,8 +33,10 @@ RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
"
-distutils_enable_tests pytest
-
-BDEPEND+="
- test? ( app-editors/neovim )
+BDEPEND="
+ test? (
+ app-editors/neovim
+ )
"
+
+distutils_enable_tests pytest