summaryrefslogtreecommitdiff
path: root/dev-python/nuitka
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest6
-rw-r--r--dev-python/nuitka/nuitka-0.6.11.ebuild (renamed from dev-python/nuitka/nuitka-0.6.9.1.ebuild)20
-rw-r--r--dev-python/nuitka/nuitka-0.6.9.6.ebuild43
3 files changed, 16 insertions, 53 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 9af788eee5e0..d0bc8444643d 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,5 +1,3 @@
-DIST Nuitka-0.6.9.1.tar.gz 2470517 BLAKE2B b3162eed308d98846a6266fa822d851757773ef9910a250644d61627d70dcc29706f5127221e2c09b1f856b74262c64f10cc638ec336a53d1fd6a10ad53e4e29 SHA512 a94a2e7f86abdbbdaa0147e569ff873c4d0f439378afb0f55ce78ea6e22a16ac759b62fd617944e0a4cf98fbe3294db5e56c3b3a6bd8cb78bd1c1132d557f6a9
-DIST Nuitka-0.6.9.6.tar.gz 2472086 BLAKE2B acee6dc787f24afb6c1843e82bd4fdcda3a45c4c8a74cb5635d5fb2aec6b1a8db64920993b1732e21f3d0866e47f81cd958f42fe577c592931053248976ab33a SHA512 9a4d2b0e947e26118c9e81fc93c63ccc344a0a4d577e2ccd2d6b1ccafacef3eb3d7424283e681b63dde44fa51aad84d86f76e2c839d22d7d1503730e0ab72ab8
-EBUILD nuitka-0.6.9.1.ebuild 1041 BLAKE2B 631478c3ec34f885be0750eb43db77ac833966e7bcc9747d85179dda67a9beb1cf3261cf10cffe668007dc009a06a917168c6a6acb87fdd5aaaf840e0d6000fa SHA512 5d5910f7cc1324fbd0ff44c964f3f4d09bc130933edd88873fbbba8dda9b5fb7c57bc0e9c00fe611384e2167e2c9e31204650e6b8efd6bab5862ba2db982b1e0
-EBUILD nuitka-0.6.9.6.ebuild 1041 BLAKE2B 631478c3ec34f885be0750eb43db77ac833966e7bcc9747d85179dda67a9beb1cf3261cf10cffe668007dc009a06a917168c6a6acb87fdd5aaaf840e0d6000fa SHA512 5d5910f7cc1324fbd0ff44c964f3f4d09bc130933edd88873fbbba8dda9b5fb7c57bc0e9c00fe611384e2167e2c9e31204650e6b8efd6bab5862ba2db982b1e0
+DIST Nuitka-0.6.11.tar.gz 2582563 BLAKE2B e65c3a01f3283b24aadefc47a17a41ebae116265946c24f2225fa7f3f6f824a0a822c76aa2fa1ff33b5a00d4d3762bbac7cd0d090d2627274155b13a48d8f0ba SHA512 c1ead8430f0af3a20d7a14ae3cb34b9a4675c18f0c775e8833b5722cb0acdd8213b28639e52067b3e6758b8b6cc516b05151cfd85560630c92b872dae05a88b4
+EBUILD nuitka-0.6.11.ebuild 1190 BLAKE2B 6f990cf0534960f12446bc88e5423ce5febfb64a323e2588a0fd5a1e55cc78610b5a9ed4a7dca119f7a637714c9bbf7bdc4c656cdfafac721b0e7e46d9b8f403 SHA512 4df59182686248e9741cf0945290417a91d00b8092aeb956370e80cdefb1f102651ba7d38b72e544409c3ec9305ef6db931d7c3affcb5ae0291dab37dadf695e
MISC metadata.xml 811 BLAKE2B b82c8f4dbb8b39e58fae657df8945060c91fce0eb33f0e1e16ecebffa91c41fd306e8c04bcd799dc736dc3bdac3ce843f30af04b18bb4d36407a43c07ec65d12 SHA512 368becbd858e0963f23ceffa612de4f15087a9b879d3a4efad209668a5c897d7881b82c0de9127d31208825af39c60785601a3f31f3191af7fe99285f103d18f
diff --git a/dev-python/nuitka/nuitka-0.6.9.1.ebuild b/dev-python/nuitka/nuitka-0.6.11.ebuild
index 0b8a77447b0c..57e38e5bb248 100644
--- a/dev-python/nuitka/nuitka-0.6.9.1.ebuild
+++ b/dev-python/nuitka/nuitka-0.6.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS="rdepend"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1 optfeature
+inherit distutils-r1 flag-o-matic optfeature
DESCRIPTION="Python to native compiler"
HOMEPAGE="https://www.nuitka.net"
@@ -16,11 +16,14 @@ SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
-BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-
-RDEPEND="${BDEPEND}
- dev-python/appdirs[${PYTHON_USEDEP}]"
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
S="${WORKDIR}/${P^}"
@@ -38,6 +41,11 @@ python_install() {
doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
}
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
pkg_postinst() {
optfeature "support for stand-alone executables" app-admin/chrpath
}
diff --git a/dev-python/nuitka/nuitka-0.6.9.6.ebuild b/dev-python/nuitka/nuitka-0.6.9.6.ebuild
deleted file mode 100644
index 0b8a77447b0c..000000000000
--- a/dev-python/nuitka/nuitka-0.6.9.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-
-RDEPEND="${BDEPEND}
- dev-python/appdirs[${PYTHON_USEDEP}]"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-S="${WORKDIR}/${P^}"
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
- doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}