summaryrefslogtreecommitdiff
path: root/dev-python/nuitka
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest6
-rw-r--r--dev-python/nuitka/metadata.xml4
-rw-r--r--dev-python/nuitka/nuitka-0.6.11.ebuild7
-rw-r--r--dev-python/nuitka/nuitka-0.6.15.ebuild48
4 files changed, 58 insertions, 7 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 46c5c872aff2..2443be6fa80e 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,3 +1,5 @@
DIST Nuitka-0.6.11.tar.gz 2582563 BLAKE2B e65c3a01f3283b24aadefc47a17a41ebae116265946c24f2225fa7f3f6f824a0a822c76aa2fa1ff33b5a00d4d3762bbac7cd0d090d2627274155b13a48d8f0ba SHA512 c1ead8430f0af3a20d7a14ae3cb34b9a4675c18f0c775e8833b5722cb0acdd8213b28639e52067b3e6758b8b6cc516b05151cfd85560630c92b872dae05a88b4
-EBUILD nuitka-0.6.11.ebuild 1188 BLAKE2B e330144fc75d0d8ac39391ea205b221672f8b93f4034e14e978bf4e9a306fd8dda244ed9184edb1a6c9fe8703f89f60ffad688216963246b4bea54e494026513 SHA512 ee23c9d30112bfd85e7a313fe2cb044d3ab1eadf7ce97d1dc03219d9c1a444dd1414e04794f50bfa87a096d0b33ca58792757c7cfc120ba10cb84d71dcf1295d
-MISC metadata.xml 841 BLAKE2B efca2f349ecd0eeff87ec403e691102ff6f8a2a3b6e61ebe463064d4b4d7655bfb09a7fee840371b64df4426f8e9f6db0d801e9e0c5bb020c362bc9eeb1e9c93 SHA512 3a32cf40d2c9f66e25a7410c2fb2dff81e927f4bba6ad492b5a9f127914678d23d2fe3d73cee540bd4f336995bbbec5efa2fc05b38eec30333c313f2b43599cd
+DIST Nuitka-0.6.15.tar.gz 2712097 BLAKE2B 78c43be4a2ef5678d7a0d6164d7cba2b3a67a738215915b001cdb3774e209fcecc167c52db4c3b22d87dde9169e48077875d09f8601df7c8b079e3d57b21aea6 SHA512 9a41e9b8fb3f51ec16dccd5415b3b7d7d201230fea6aff902931be1764ba65e1d5e4885cd772b4c1cb9f36b1b14a02a73351bc5c1b8e7f7bbb87e5d74aad16b4
+EBUILD nuitka-0.6.11.ebuild 1152 BLAKE2B e8d9bba83ca5b1766037e8b0154839fbc456920dcec7d4762a106a09e3ee010becdf3872c8260cdf87c9aae9c5135e5383af63568eddf2aa733563237f7b5ccf SHA512 611dd278f1d44692977293c59d5d6f2a3f490c8352b50b0c2c0dd36852d175e5b6fc4be67bb8a68082245c9d27b430b0b7b8eb568f45241401d33acd697d35de
+EBUILD nuitka-0.6.15.ebuild 1152 BLAKE2B e8d9bba83ca5b1766037e8b0154839fbc456920dcec7d4762a106a09e3ee010becdf3872c8260cdf87c9aae9c5135e5383af63568eddf2aa733563237f7b5ccf SHA512 611dd278f1d44692977293c59d5d6f2a3f490c8352b50b0c2c0dd36852d175e5b6fc4be67bb8a68082245c9d27b430b0b7b8eb568f45241401d33acd697d35de
+MISC metadata.xml 942 BLAKE2B ec5857515914046bc074009149a2e830fd94da026e6563984f914d72183595617e1437e1d3dcff9caeeca20fe0f2be0cf33d45489a36bfde05b35815a9a34df2 SHA512 c2bcbedbfaf567f0813291fc890fccf9d59fa52808317cde9bbdfdda79337f15a1e6551587557bc0bf8ea27f5cc646674d3857c1c960f72469730fa23a43eac2
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
index ea8a6d087e33..bfddacd6504f 100644
--- a/dev-python/nuitka/metadata.xml
+++ b/dev-python/nuitka/metadata.xml
@@ -9,6 +9,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<longdescription lang="en">
Python compiler with full language support and CPython compatibility
This Python compiler achieves full language compatibility and compiles Python
diff --git a/dev-python/nuitka/nuitka-0.6.11.ebuild b/dev-python/nuitka/nuitka-0.6.11.ebuild
index 739ff9dd18cd..d45a2f3b311d 100644
--- a/dev-python/nuitka/nuitka-0.6.11.ebuild
+++ b/dev-python/nuitka/nuitka-0.6.11.ebuild
@@ -3,15 +3,13 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-PYTHON_COMPAT=( python3_{7,8} )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 flag-o-matic optfeature
DESCRIPTION="Python to native compiler"
HOMEPAGE="https://www.nuitka.net"
SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -26,7 +24,6 @@ BDEPEND="
"
DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-S="${WORKDIR}/${P^}"
distutils-r1_src_prepare() {
# remove vendored version of SCons that is Python2 only
diff --git a/dev-python/nuitka/nuitka-0.6.15.ebuild b/dev-python/nuitka/nuitka-0.6.15.ebuild
new file mode 100644
index 000000000000..d45a2f3b311d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}