summaryrefslogtreecommitdiff
path: root/dev-python/numpy/numpy-1.26.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpy/numpy-1.26.1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.26.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-1.26.1.ebuild b/dev-python/numpy/numpy-1.26.1.ebuild
index 955652eea0d8..03c05aeaa686 100644
--- a/dev-python/numpy/numpy-1.26.1.ebuild
+++ b/dev-python/numpy/numpy-1.26.1.ebuild
@@ -49,6 +49,7 @@ BDEPEND="
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/${PN}-1.26.1-alpha.patch" )
EPYTEST_XDIST=1
distutils_enable_tests pytest
@@ -142,6 +143,13 @@ python_test() {
;;
esac
+ if ! has_version -b "~${CATEGORY}/${P}[${PYTHON_USEDEP}]" ; then
+ # depends on importing numpy.random from system namespace
+ EPYTEST_DESELECT+=(
+ 'random/tests/test_extending.py::test_cython'
+ )
+ fi
+
rm -rf numpy || die
epytest --pyargs numpy
}