summaryrefslogtreecommitdiff
path: root/dev-python/openapi-core
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest4
-rw-r--r--dev-python/openapi-core/metadata.xml2
-rw-r--r--dev-python/openapi-core/openapi-core-0.16.6.ebuild68
3 files changed, 72 insertions, 2 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 42234d53ddf0..040c1b61f7a0 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,3 +1,5 @@
DIST openapi-core-0.16.5.gh.tar.gz 104046 BLAKE2B 7dcda69b6d548a0df8c7727b184c7f7ec6d645e14ab4b4a256f188c6cc4ae9e351bc06ae03770782d81a11dfb5ebc08c20daabbd2151cfe62f84b05f80a47a16 SHA512 59db6d39a950079739b2df4114f26d85be55dc1f42d1661e8e6c17cf878cd8167f29ba4d3b6f40e06e85bb144c68286cb50adf4403091461798144cac05d5bc0
+DIST openapi-core-0.16.6.gh.tar.gz 104008 BLAKE2B bb1bdac98dfc5aef0961624488074363568f53a6c44cb0730be0d103d891d24bed86659f640e0d07da4072edc233c904c0ddcfd9e8b3960ace1af078c0d745e5 SHA512 556636a4698dcd7db6c656333849077abacdac1a440fe58210ad8f02c1f0220e46dea29962346dfb3f89d164ebc986ec750c184840be9a34a5e1dd98fbf8ef98
EBUILD openapi-core-0.16.5.ebuild 1828 BLAKE2B 01098a654afb770ece9c121af506d42053169d6ee173547175c47a4f11d17e618ba3eae45b7e07719fe946aee3d6102f90e93f3f642fc47bdd29d66c453fe357 SHA512 11c04c4ffb99871884fa70ca1f8d7087a4418731c9a46b49236446f764f1e1da0470cb24eb91f71a34ed6e97885d4daf3a25fa8ad50765690039d610b235a418
-MISC metadata.xml 376 BLAKE2B bf1f9cf9377b172dfb5f916332dbf9d1e485f3ca1f31f754afac41931598c1780c474989edbfcf39bbfd4ceb8e8030280cf0997514dfb8e02bf3294176fc3dfd SHA512 c7fbdc21a2ea86abe5bcf4a3e8ba97634a447926ce999aff761965ff411fb05b09fab5e5338da5f8a8486a6b024cfeb27cfb9d9fbbfc9bad6f9dabaca1c82799
+EBUILD openapi-core-0.16.6.ebuild 1846 BLAKE2B 73ce79257fb849664a63d4f0db159582f2926139119b1715498845b623f10b9acaeceafc0b6e95bf3631d02e3120c8f44e0d83e9b8eb76a5895531e848d4f8e9 SHA512 bdf757cf5d152b2bd0e56c1ff30f23293794e1f89a227b2ce322865d39fafe8068ae114e24ef59bc9467d73ab14486e237b4bb9e4fe059d529cfd1f4b2558066
+MISC metadata.xml 385 BLAKE2B a19f5b70529b6f0575e1196f3ffe0a7f38595fe7b01b43119f0f89c41a9ab5d6992f424a10f345a7407d279736a6091918b9ba1ead0daa92c9d244e4b27e4a18 SHA512 a8a39c8958ad11de5eb6896a74b3bfcb27e95c74a984a362032e4703d86f2831b6559a96a8eef80a7ef89f4687da325b3748f36b1df649cd29c2acb1ea0c9969
diff --git a/dev-python/openapi-core/metadata.xml b/dev-python/openapi-core/metadata.xml
index 13f408253cd2..b58a890a8a64 100644
--- a/dev-python/openapi-core/metadata.xml
+++ b/dev-python/openapi-core/metadata.xml
@@ -5,7 +5,7 @@
<email>python@gentoo.org</email>
</maintainer>
<upstream>
- <remote-id type="github">p1c2u/openapi-core</remote-id>
+ <remote-id type="github">python-openapi/openapi-core</remote-id>
<remote-id type="pypi">openapi-core</remote-id>
</upstream>
<stabilize-allarches/>
diff --git a/dev-python/openapi-core/openapi-core-0.16.6.ebuild b/dev-python/openapi-core/openapi-core-0.16.6.ebuild
new file mode 100644
index 000000000000..34f3bb300c13
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.16.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+SRC_URI="
+ https://github.com/python-openapi/openapi-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # falcon is not packaged
+ tests/integration/contrib/falcon
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}