summaryrefslogtreecommitdiff
path: root/dev-python/ordered-set/ordered-set-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ordered-set/ordered-set-4.1.0.ebuild')
-rw-r--r--dev-python/ordered-set/ordered-set-4.1.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ordered-set/ordered-set-4.1.0.ebuild b/dev-python/ordered-set/ordered-set-4.1.0.ebuild
new file mode 100644
index 000000000000..df47200b0a3b
--- /dev/null
+++ b/dev-python/ordered-set/ordered-set-4.1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A mutable set that remembers the order of its entries"
+HOMEPAGE="https://github.com/rspeer/ordered-set"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest