summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild')
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
new file mode 100644
index 000000000000..ce6ed7140c4a
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"