summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest6
-rw-r--r--dev-python/oslo-i18n/metadata.xml4
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild (renamed from dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild)19
3 files changed, 21 insertions, 8 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index 4736d2bb10bd..85bd29c4acc1 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1,3 +1,3 @@
-DIST oslo-i18n-5.0.1.tar.gz 44636 BLAKE2B 69df723bff7a279ace2a8bb2ea795e6beaa626ffc4bb364c513d16d2ce3cb07f6e9957a98d1b633f95154672d118de6fbb71ef5c1a3a53520f4d1f4b8f72748f SHA512 d55238616dc90f85ff458fc6680b3a3b2493d2a640bf5849c19cd7271e7127b535a301ed3085b5e0131b46a635b5a09423f6cba60f9f1b9b0352a0e7115a8057
-EBUILD oslo-i18n-5.0.1.ebuild 626 BLAKE2B cad76aa12b12d4c7d8bc1ff3aa3b4a211638a88968811e998cabec466d1e42689f58849622479a8f060957bea23b6a045a9251caad4db6a8a51f580714617faf SHA512 36e8c89876800fed68842bd62799f7196d440c38bcb7a7e1b4c22ab6f684b5de6160a41dd05149c5bd7f934d9dfa216fc43acd29a0dc6faff8cf689b62b2d344
-MISC metadata.xml 504 BLAKE2B 646830c9f625ec395265019b730dad69b5359ec85c56bdbd84b98149f05ab04381cd44f8952bcbe1a939dc0b09c7ee492043d4b0d2ece0b0b04bfc7124f6e675 SHA512 305c7352a138341af2ad61c72928e6b3a0b1f6c86d8aab8aa5636a7404161dce1500a482cdbc4c7c08ff7cbc7f1a518302195f9edd95ae65ba2657f1ff75b169
+DIST oslo.i18n-5.0.1.tar.gz 44636 BLAKE2B 69df723bff7a279ace2a8bb2ea795e6beaa626ffc4bb364c513d16d2ce3cb07f6e9957a98d1b633f95154672d118de6fbb71ef5c1a3a53520f4d1f4b8f72748f SHA512 d55238616dc90f85ff458fc6680b3a3b2493d2a640bf5849c19cd7271e7127b535a301ed3085b5e0131b46a635b5a09423f6cba60f9f1b9b0352a0e7115a8057
+EBUILD oslo-i18n-5.0.1-r1.ebuild 750 BLAKE2B cea3aecfa9357b3ae1886be8aada131674733084c89242e7537dbe64d04bc42714e91c7331aaa94f387e68e6a8f1d91dc498a9cfc89ed7eb9d6f00087e041f85 SHA512 926fc45ddd8fba80942f87cd3e60e1c53d391ce15f22ab66ba2edf49faee1146bef21a3a89844a67d7e0ce95ffd7c2c52543c637f67af2cca84d6f6b370deb1e
+MISC metadata.xml 605 BLAKE2B 7393a374b976ee7fa9416ba5f431ab99a8e760580bc9aae7fff4249085c4341c3dbf8cc2e86270061ab5abb36be34811317735f75afe344c7f5f3bf54dcacad4 SHA512 31d7ab85bb31cad7907712039a5032b42bdb69ee50a402d6c368b3501e9a768e77097021477fb9dbbf24a43823e6b78249e40bee097b366c6c83e5b151117be6
diff --git a/dev-python/oslo-i18n/metadata.xml b/dev-python/oslo-i18n/metadata.xml
index 622ac75e5084..0e46ed659e40 100644
--- a/dev-python/oslo-i18n/metadata.xml
+++ b/dev-python/oslo-i18n/metadata.xml
@@ -9,6 +9,10 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">oslo.i18n</remote-id>
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild
index 940d62e22546..29cb1ee5c79f 100644
--- a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
+++ b/dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild
@@ -2,16 +2,17 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1 vcs-snapshot
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
DESCRIPTION="Oslo i18n library"
HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
@@ -19,8 +20,16 @@ KEYWORDS="amd64 ~arm arm64 x86"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"
+BDEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest