summaryrefslogtreecommitdiff
path: root/dev-python/packaging/files/packaging-16.8-distutils.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/packaging/files/packaging-16.8-distutils.patch')
-rw-r--r--dev-python/packaging/files/packaging-16.8-distutils.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/packaging/files/packaging-16.8-distutils.patch b/dev-python/packaging/files/packaging-16.8-distutils.patch
new file mode 100644
index 000000000000..84bbb618a6fe
--- /dev/null
+++ b/dev-python/packaging/files/packaging-16.8-distutils.patch
@@ -0,0 +1,14 @@
+--- a/setup.py
++++ b/setup.py
+@@ -13,10 +13,7 @@ import re
+ # dependency when projects attempt to unbundle stuff from setuptools and pip.
+ # Though we don't really support that, it makes things easier if we do this and
+ # should hopefully cause less issues for end users.
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+
+ base_dir = os.path.dirname(__file__)