summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.19.3.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 1a464fe13685..af992703e344 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,7 +1,9 @@
DIST pdm-2.18.2.tar.gz 2629592 BLAKE2B 74b128e60409ab7d374a195f30124802af7cdd1c2857d2b925e633a974e752706236570b6ec1fa0827a081427156e7bb858a0385696ce6fe49ace83cd5aea95f SHA512 87187e0b036e7f462bd23e92a4dbf402a3b9ced6679acc08b0645369d463d2bb257853858f7e7bc2416749dd2233e94aaaa206febe0aa35b80e6d23dde88b7b8
DIST pdm-2.19.1.tar.gz 2637357 BLAKE2B 55116766dc1dc45e4e1f3720cd62dc5cb8e3c662aa0d4999918a02cfaa4db24b81e9fdc363d516b2b967141829be6006bd3f9401b0074c1aa29ff9d644ef9540 SHA512 e13d0b91437478f392f1b4ae319155b79aa103082733b63288187239705706dc9bce8014cd85d5895cd9d75944dbdb8141606098ccc511644ed3d83f93abf6cd
DIST pdm-2.19.2.tar.gz 2638029 BLAKE2B 17e173495e19d915fabf353e20479943d1ce44048f853dc538067dce75e271f88c3bda411e749def51d50f7e8c14f26e1bf548531b63ca2cca0efb8c7f536d0f SHA512 85922aaebce9eba3d59d280d4e8913be1505c8a6e01c0d20f79233b60cb2fe9388cf1ec9ea1a6fb3b7ae9a05d2e20c860f8065dfbe8746f6f9c1bac5bf7ef585
+DIST pdm-2.19.3.tar.gz 2639417 BLAKE2B aa9930ea4a6b358ee82f111c7baac788fdc30e6aa20189e22d979716af306bd792a4b91654c39d915cbf812e07019692519a1acd65a7404dd5e7cafb4702c26c SHA512 05542e260d9849ae1b186df0e237a15e23e6c4b7442c2f9cbcbf593e88136831d724eecfebad2a7ba3deda13f20ed9b6a322ec12f1a3eb6f5f8e0e396312f333
EBUILD pdm-2.18.2.ebuild 5137 BLAKE2B d740a92c31dfb28e57a111c5a2a50f0a5720ee93c513232a52ea9b68d0dd0ba7b8c03fc5320aaf13b6d1a678fc378c1b8dc1f37f2cf055a821ab89ac48079258 SHA512 c4fb063ee347250e8cbfc3aed4a57ef20493ac98b6131d1b714c26b0992e01cbd8c1c15e8ee7e8c8cf0ee16f5cfe66ef112fd7cf9afb47d2bfc8561a724479c5
EBUILD pdm-2.19.1.ebuild 5137 BLAKE2B d740a92c31dfb28e57a111c5a2a50f0a5720ee93c513232a52ea9b68d0dd0ba7b8c03fc5320aaf13b6d1a678fc378c1b8dc1f37f2cf055a821ab89ac48079258 SHA512 c4fb063ee347250e8cbfc3aed4a57ef20493ac98b6131d1b714c26b0992e01cbd8c1c15e8ee7e8c8cf0ee16f5cfe66ef112fd7cf9afb47d2bfc8561a724479c5
EBUILD pdm-2.19.2.ebuild 5146 BLAKE2B a1d05c25cddf739a3097f7b7d2153ca599dd59ba8e1f8dd7d296fce516870dc3fb34c74c1f28ac637c8624105703c0e93647654fb63a118a64b7ca26a4c43c20 SHA512 50bdeaf3d39a875069225140585c9186d6412b843522198530586d7fe2c4aeb715912639a6c474d7c0cc2aca0de64ee53ce24e767a998f0e4ef58fd8b9579f3c
+EBUILD pdm-2.19.3.ebuild 5146 BLAKE2B a1d05c25cddf739a3097f7b7d2153ca599dd59ba8e1f8dd7d296fce516870dc3fb34c74c1f28ac637c8624105703c0e93647654fb63a118a64b7ca26a4c43c20 SHA512 50bdeaf3d39a875069225140585c9186d6412b843522198530586d7fe2c4aeb715912639a6c474d7c0cc2aca0de64ee53ce24e767a998f0e4ef58fd8b9579f3c
MISC metadata.xml 474 BLAKE2B c1471e124a955920e30f73dfa43a87999c30c2bb9615590f601befcc07f7d939ec68908e67c7345fca4cb0f0524d33507aeac9936fa30d449d1dde17094048d3 SHA512 a07256061dda5a8cf8b0e15205ac36651a4e5b594fdedbfe16d1d3264e1ac42847d1dc222d2857232ac5206d67feda432751695d85d0c4c7b03fd7228db8b1ab
diff --git a/dev-python/pdm/pdm-2.19.3.ebuild b/dev-python/pdm/pdm-2.19.3.ebuild
new file mode 100644
index 000000000000..bbb6902a684e
--- /dev/null
+++ b/dev-python/pdm/pdm-2.19.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm-project.org/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/dep-logic-0.4.4[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/truststore-0.9[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/hishel-0.0.32[${PYTHON_USEDEP}]
+ >=dev-python/pbs-installer-2024.4.18[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.17.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ "tests/test_project.py::test_find_interpreters_with_PDM_IGNORE_ACTIVE_VENV[True]"
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ tests/models/test_candidates.py::test_find_candidates_from_find_links
+ tests/cli/test_build.py::test_build_single_module
+ tests/cli/test_build.py::test_build_single_module_with_readme
+ tests/cli/test_build.py::test_build_package
+ tests/cli/test_build.py::test_build_src_package
+ tests/cli/test_build.py::test_build_package_include
+ tests/cli/test_build.py::test_build_src_package_by_include
+ tests/cli/test_build.py::test_build_with_config_settings
+ tests/cli/test_build.py::test_cli_build_with_config_settings
+ tests/cli/test_build.py::test_build_ignoring_pip_environment
+ tests/cli/test_others.py::test_show_self_package
+ tests/cli/test_publish.py::test_publish_and_build_in_one_run
+ "tests/cli/test_hooks.py::test_hooks[build]"
+ "tests/cli/test_hooks.py::test_hooks[publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
+ "tests/cli/test_venv.py::test_conda_backend_create[True]"
+ "tests/cli/test_venv.py::test_conda_backend_create[False]"
+ tests/cli/test_lock.py::test_lock_all_with_excluded_groups
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ # fails in tinderbox (bug #928964)
+ tests/test_project.py::test_project_packages_path
+ # i guess doesn't expect some dep to be present
+ tests/cli/test_build.py::test_build_with_no_isolation
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock
+}