summaryrefslogtreecommitdiff
path: root/dev-python/pefile/pefile-2022.5.30-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pefile/pefile-2022.5.30-r1.ebuild')
-rw-r--r--dev-python/pefile/pefile-2022.5.30-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pefile/pefile-2022.5.30-r1.ebuild b/dev-python/pefile/pefile-2022.5.30-r1.ebuild
new file mode 100644
index 000000000000..cc72cfce3ddc
--- /dev/null
+++ b/dev-python/pefile/pefile-2022.5.30-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-future.patch"
+)
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.