summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest4
-rw-r--r--dev-python/pexpect/pexpect-4.2.1.ebuild6
-rw-r--r--dev-python/pexpect/pexpect-4.6.0.ebuild40
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index ea9510d88ca5..d0c01686b46b 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,3 +1,5 @@
DIST pexpect-4.2.1.tar.gz 143980 BLAKE2B b5cb9c7847eabdf8778bddc6b208520edb9b3611d7a981fae6e371fa6deafebe142ba8361e3a1d21187cd692576c91d732f3def75e19989296f50b2a9fb4d4c6 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261
-EBUILD pexpect-4.2.1.ebuild 1162 BLAKE2B 441552088625ea18bbb4944ff66d40e2f29afc05a57d042fbc2526735ee94459522772f3c7b9b6916db56034df71a8f35570396b6d31b515c3ac5ac55a5e339f SHA512 ca44c829566aabf1b45e7a7996733bbb67d6ad71e8b1ffccb3ac040cdb26fda5c5394c2af8c7bd9d5ce17812e9d4457000c8de1846b649667160578605571883
+DIST pexpect-4.6.0.tar.gz 148966 BLAKE2B 0ed1a3c31133bf618e4c75ea099efaa9bda9e2b7f92f46c54ad553ecc56487e5415b750334376a95599ada53e17e91efe7d4b65ad80bb4f6a1cf9d655a3c9685 SHA512 9a2b1ef19d885e69cfd17ba0519581f782574019010043e66d8b68f98ac86b359f4a1ca42f8bb0059a5dfdd43275ad93531c076cc0ac2049e109408961b46bbd
+EBUILD pexpect-4.2.1.ebuild 1153 BLAKE2B 9ca26fa04abe4635e801d2282756f85c239f751d70a6439b6ed80744fd4b4945596c9b5e06d6139e441da1d1ba4fbdb407c13d09c409c501d725afa02da1ad74 SHA512 1cf058c3f89c008f842d3fa38355c51cb68360adebc29e41559f88fd948b5d3628be75f07befe70caeb1d5974bfb190308222e903cfbf941d80984e213281874
+EBUILD pexpect-4.6.0.ebuild 1163 BLAKE2B ee742e86458817c49cfb16d564b3f5d365d6f9bd6d7920dd1cae1a53fd17bf92069877c73b093da2e236f885e4a49003791aa4d14869a40dcedd0365361aed37 SHA512 e6603b00b42e2aa8dbdfacddd582ef23f32c199e852a7776fdf5e86306b298a9819b787fafda7e9937f79995eb7cbae6ac760ab10eb2380f00b4d854a6c55ca5
MISC metadata.xml 377 BLAKE2B 72c4b35c12a770df9344987af8c7a392c3aed05296a4876902987ef946239f8318ee833cc81a7f004719e954670a83e84a3813bcdaac48912efad885515de1ea SHA512 31e65b2ce9ec12e9d3e95ed651841b8aad6a24330fe20b4bfd6351267423ff5005ac3cb2e89dbb8f024cf60705d3f06a8a1309169a029eb5246ddc45a8d76464
diff --git a/dev-python/pexpect/pexpect-4.2.1.ebuild b/dev-python/pexpect/pexpect-4.2.1.ebuild
index 4ec6aea19456..f42f3bd52ca8 100644
--- a/dev-python/pexpect/pexpect-4.2.1.ebuild
+++ b/dev-python/pexpect/pexpect-4.2.1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
diff --git a/dev-python/pexpect/pexpect-4.6.0.ebuild b/dev-python/pexpect/pexpect-4.6.0.ebuild
new file mode 100644
index 000000000000..02f1b078ff97
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
+HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}