summaryrefslogtreecommitdiff
path: root/dev-python/pickleshare/pickleshare-0.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pickleshare/pickleshare-0.7.3.ebuild')
-rw-r--r--dev-python/pickleshare/pickleshare-0.7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pickleshare/pickleshare-0.7.3.ebuild b/dev-python/pickleshare/pickleshare-0.7.3.ebuild
new file mode 100644
index 000000000000..71f132a2150d
--- /dev/null
+++ b/dev-python/pickleshare/pickleshare-0.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small 'shelve' like datastore with concurrency support"
+HOMEPAGE="https://github.com/pickleshare/pickleshare"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/pathlib[${PYTHON_USEDEP}]' python2_7 python3_3)
+ >=dev-python/path-py-6.2[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ py.test || die
+}