summaryrefslogtreecommitdiff
path: root/dev-python/pillow/pillow-6.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pillow/pillow-6.2.1.ebuild')
-rw-r--r--dev-python/pillow/pillow-6.2.1.ebuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/dev-python/pillow/pillow-6.2.1.ebuild b/dev-python/pillow/pillow-6.2.1.ebuild
index dbe4d52efc2f..d274e9829a3d 100644
--- a/dev-python/pillow/pillow-6.2.1.ebuild
+++ b/dev-python/pillow/pillow-6.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 toolchain-funcs virtualx
@@ -14,11 +14,12 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Python Imaging Library (fork)"
HOMEPAGE="https://python-pillow.org/"
SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="HPND"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
REQUIRED_USE="test? ( jpeg tiff )"
RESTRICT="!test? ( test )"
@@ -34,17 +35,14 @@ RDEPEND="
zlib? ( sys-libs/zlib:0= )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
test? (
dev-python/pytest[${PYTHON_USEDEP}]
media-gfx/imagemagick[png]
)
"
-S="${WORKDIR}/${MY_P}"
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
python_configure_all() {
# It's important that these flags are also passed during the install phase
@@ -75,16 +73,12 @@ python_configure_all() {
tc-export PKG_CONFIG
}
-python_compile_all() {
- use doc && emake -C docs html
-}
-
src_test() {
virtx distutils-r1_src_test
}
python_test() {
- "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
}
@@ -95,7 +89,6 @@ python_install() {
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
if use examples ; then
docinto example
dodoc docs/example/*