summaryrefslogtreecommitdiff
path: root/dev-python/pip-run
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest2
-rw-r--r--dev-python/pip-run/pip-run-12.6.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 9587fb28bd47..0c6593b6d008 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,3 +1,5 @@
DIST pip-run-12.5.0.tar.gz 38695 BLAKE2B a44d35752586bd6d27a2d7e7feebbf904f8552e11becd821e693716b1ef74bfb490a17aacf3b7c19656bbc21fde38e40d29c79a611b2f510c02d199afc8f5cb1 SHA512 b641633c1863745d31637b1ef2a9151c79cc0c647b1bc246dbea5e834ec928b11b29b9cee1952513340bacb1ead610c2b34426b54d76345b57c887b1fe4b68d6
+DIST pip-run-12.6.1.tar.gz 38868 BLAKE2B 852e8207fc5951a4007f761c18dd06b483a0658d3ab3f51e667b5f0a204fe2f2c530ade5d2d36005c2a25d564cb779b5d2911aeaf5e046477631958172414352 SHA512 b4dcdf0d96061b7049bd8ad25e20f36fe305fe04148937cab3be91ab8fc95849b07b14d2948eb0d5172d36f5ef561b80cff07b1203c62f117c52eb5d265e9356
EBUILD pip-run-12.5.0.ebuild 1312 BLAKE2B 0b849d7ea3f1edea92de51eda9d471219a9301225dd785fc5697c791cc9c40d05ca5d8a3377341b240b2464e5c06ac43f5f5d96230332500620e75933cadac3f SHA512 2d4cad1ecc212e7239b4dd9964ab49b1a7cbf559c8cec6f61f0d0bd84249bc7989202fb5b5e81045527f2502fef0a38af4851de4bef11c1dfba8c4fa6c4f957b
+EBUILD pip-run-12.6.1.ebuild 1320 BLAKE2B 3d23fcf884bafde2fea340c957509360c0a5cc477631735c786634eed96537dd5d5052a2cea6912792e538fd6a10c956b61ecb9f090dd354186c2623f4138454 SHA512 61151bf19a99a40809b51d9a8c8d19ca8fb08ae9f91cab3cb51fec564e848a0a9f26586bb4e7d08e40032aa534db69572f07ab6c93816e61c195af3f7b17f7fc
MISC metadata.xml 389 BLAKE2B bc573b4f57b4f8371ecef97266b8441d47e66d551f7088a7f312ca049f7debd90e989d24d59d7aff182795ae27e553d131f3875c789dc793532ff9c812bcaf20 SHA512 00b81cba684e7118a3ce79ec5cb6a27d6ad67064a2745ffead8dec51c7786c9441139b800868cad8854ff39d7e38163ab2c8fa5c7d3f328390b628f8342fb0ca
diff --git a/dev-python/pip-run/pip-run-12.6.1.ebuild b/dev-python/pip-run/pip-run-12.6.1.ebuild
new file mode 100644
index 000000000000..18908d5d7407
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.6.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m "not network"
+}