summaryrefslogtreecommitdiff
path: root/dev-python/pip/pip-21.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip/pip-21.1.2.ebuild')
-rw-r--r--dev-python/pip/pip-21.1.2.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/dev-python/pip/pip-21.1.2.ebuild b/dev-python/pip/pip-21.1.2.ebuild
index 5aaeef43de3e..7ca3bf655d51 100644
--- a/dev-python/pip/pip-21.1.2.ebuild
+++ b/dev-python/pip/pip-21.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="ssl(+),threads(+)"
inherit bash-completion-r1 distutils-r1
@@ -29,7 +29,7 @@ SRC_URI="
LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
SLOT="0"
-IUSE="test -vanilla"
+IUSE="test vanilla"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -38,17 +38,16 @@ RDEPEND="
BDEPEND="
${RDEPEND}
test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/csv23[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/scripttest[${PYTHON_USEDEP}]
- <dev-python/virtualenv-20[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/scripttest[${PYTHON_USEDEP}]
+ <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' python3_{7..9})
)
"
@@ -75,6 +74,12 @@ python_test() {
return 0
fi
+ # virtualenv-16 doesn't support python3_10 yet is still required by pip test suite
+ if [[ ${EPYTHON} == "python3.10" ]]; then
+ ewarn "Skipping tests on ${EPYTHON} due to missing dependencies"
+ return 0
+ fi
+
local deselect=(
tests/functional/test_install.py::test_double_install_fail
tests/functional/test_list.py::test_multiple_exclude_and_normalization