summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild')
-rw-r--r--dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild b/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild
deleted file mode 100644
index f35c13ebc2f0..000000000000
--- a/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
-HOMEPAGE="
- https://pypi.org/project/platformdirs/
- https://github.com/platformdirs/platformdirs/
-"
-SRC_URI="
- https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- grep -q 'build-backend = "hatchling' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "${PN}"
- version = "${PV}"
- description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
- EOF
- # sigh
- cat > src/platformdirs/version.py <<-EOF || die
- __version__ = version = '${PV}'
- __version_tuple__ = version_tuple = (${PV//./, })
- EOF
-}