summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy/pluggy-0.7.1.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.7.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pluggy/pluggy-0.7.1.ebuild b/dev-python/pluggy/pluggy-0.7.1.ebuild
index 2ccc546cb187..dd9526ce4e72 100644
--- a/dev-python/pluggy/pluggy-0.7.1.ebuild
+++ b/dev-python/pluggy/pluggy-0.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,10 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.1-disable-broken-tests.patch"
+)
+
python_test() {
PYTHONPATH="${BUILD_DIR}/lib" pytest -v || die "tests failed with ${EPYTHON}"
}