summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase/pluginbase-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluginbase/pluginbase-1.0.0.ebuild')
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pluginbase/pluginbase-1.0.0.ebuild b/dev-python/pluginbase/pluginbase-1.0.0.ebuild
index 0524feaefd65..4a3320d7185e 100644
--- a/dev-python/pluginbase/pluginbase-1.0.0.ebuild
+++ b/dev-python/pluginbase/pluginbase-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
+PATCHES="${FILESDIR}/${P}-python3.9.patch"
+
python_prepare_all() {
sed -e "s/, 'sphinx.ext.intersphinx'//" \
-i docs/conf.py || die