summaryrefslogtreecommitdiff
path: root/dev-python/plyr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plyr')
-rw-r--r--dev-python/plyr/Manifest4
-rw-r--r--dev-python/plyr/plyr-1.0.6-r1.ebuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/plyr/Manifest b/dev-python/plyr/Manifest
index 57cb3c975d32..9ce240af677f 100644
--- a/dev-python/plyr/Manifest
+++ b/dev-python/plyr/Manifest
@@ -1,3 +1,3 @@
-DIST python-glyr-1.0.6.tar.gz 42952 BLAKE2B fd95ef9fd01788c6f6526eabb77cc2c93bd28324066cfb1a4be70a5990bb1599e57e40d607f926a7216c582389e9763bdc92fbd411cdeef52aa86e1ba6138c83 SHA512 c4b04b1379116048f78c3ce5f9d30c92fd0d7198bfda456891d3012d115b86a5970595d9b4bc1d43028e87c9d467c35a7d02c7f3a9f4670dae8a17c22d1ab58a
-EBUILD plyr-1.0.6-r1.ebuild 839 BLAKE2B 5675ebfccbdf52fb0f52d1050cb684928a3e3ba8d88f1c6884c183faeecda1f34b83fb8df3cc575f42478597a44039ae8e9c248905646b377384b287ec4eea14 SHA512 9c44a36066e94b913e95a1f873c174b0f2f1abca9f9b582ad5da4dc6bbeb0b566c6bceda025113e31e170157cbe89140cca8059ea83c0d43449252dd50fbb923
+DIST python-glyr-1.0.6.gh.tar.gz 42952 BLAKE2B fd95ef9fd01788c6f6526eabb77cc2c93bd28324066cfb1a4be70a5990bb1599e57e40d607f926a7216c582389e9763bdc92fbd411cdeef52aa86e1ba6138c83 SHA512 c4b04b1379116048f78c3ce5f9d30c92fd0d7198bfda456891d3012d115b86a5970595d9b4bc1d43028e87c9d467c35a7d02c7f3a9f4670dae8a17c22d1ab58a
+EBUILD plyr-1.0.6-r1.ebuild 892 BLAKE2B 2a196f88b8ae11038e109b15e2e31e7a2ba9dc6ca73055f37bcadbf7ff0f41cafc4fcf586d0746ced513d87c7f5a917d12cdd8aeef7b6e6e75590c8440180307 SHA512 cf33c1c52e47d5ba6b336aa96abce10f633bfda1c9cec9ad0174de1aaabd33cd33e4504873fb7bfdf8c45cb0fcf9ec0721776da562f0cfb3c6dc552c6c2dc2cf
MISC metadata.xml 365 BLAKE2B 8a30581cdb4603530b64093b9ba4b374d00de92743eb4548363872381142c23242f09ba32e6bbaead07a06f13d47b1fa5f89e3c5b426f057994c85709f5b49bd SHA512 6e3bb4d6ddf61f54cdd1e490c93c7f0339c58f521719c0c2aac98679c44a1d3e5ca0d064f131a67520ff47fae080e6df3029e2dccb9d158a3128df1341f574ed
diff --git a/dev-python/plyr/plyr-1.0.6-r1.ebuild b/dev-python/plyr/plyr-1.0.6-r1.ebuild
index 08662ab5dae4..bd405e8ab86d 100644
--- a/dev-python/plyr/plyr-1.0.6-r1.ebuild
+++ b/dev-python/plyr/plyr-1.0.6-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -19,7 +19,8 @@ HOMEPAGE="
https://pypi.org/project/plyr/
"
SRC_URI="
- https://github.com/sahib/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz
+ https://github.com/sahib/${MY_PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
"
S="${WORKDIR}/${MY_P}"
@@ -33,8 +34,9 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+# <cython-3: https://bugs.gentoo.org/898696
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
"
distutils_enable_sphinx docs/source