summaryrefslogtreecommitdiff
path: root/dev-python/podman
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest2
-rw-r--r--dev-python/podman/podman-5.2.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
index cae259acbf65..c1f8c6544925 100644
--- a/dev-python/podman/Manifest
+++ b/dev-python/podman/Manifest
@@ -1,3 +1,5 @@
DIST podman-py-5.0.0.gh.tar.gz 183844 BLAKE2B c2c5511815d37321a843dfe028839592f6e9b4cc580263e743b6a2ee0917b3307b77bf4d08b327781c6d765c231d8bfcc4d1e0027351c4297509433405887552 SHA512 3abcc4c989843fb82a09e32359018cb9b3352f014253def4bec46a7336c95405b50fe774192d2f4625748351c57293b70d393eb85671719833c0a9f1311612ed
+DIST podman-py-5.2.0.gh.tar.gz 186468 BLAKE2B d993e50817c6251dae4fcff8bdd9b4d125b5f96b2d5a690922ea5294cc739e2132edd4878b1dca26e1ffb7deef1e971f94a6e34c1b869dbe412c7965b49b2973 SHA512 6189415d644cf74868ccc5d560414fa876c1e0525ca028e7436a804ffe3a1219dead37223619e3d248da455856989407482638856b68cabeaf3ca4f02a9cf25c
EBUILD podman-5.0.0.ebuild 1194 BLAKE2B 44615ee89f0bb6cc42f0c76709e6b35feb070ba6e21344fe10dff66ad4ec9d5a2786a983d8c74562608e1521fd3f9221b7e0e06709065b3f01ad5e9209811585 SHA512 1b70acbe84de8bc636b75aac927efa7d1d3ef64500eb655984914b2d2c2f7cdc5d46a44a23a0fe46fc01190c73ed0296a48831c908b772b71d77e303ae25ce03
+EBUILD podman-5.2.0.ebuild 1151 BLAKE2B 9bf821ae471e25ff6d160026332567ec00b028dd644711090f287bfb4357c6bbd4a8a6588f93ed689255963f646a66c9c319ecd79e443ffd98bf0be416078063 SHA512 fd188d474951ef8c4eb39f8b1a837945cb8f7901d9e946ce8ea96da4b2716afb4ac1bf56efbc6ee8922b072d2b758928ee9fec47cd58f695ac6be5a342bc41b2
MISC metadata.xml 475 BLAKE2B 42fc2c044df94ebf8a4eb5088a39ad3075089cd5a007473db0964df4efb8c7a437c94db9c161d6ba81d2c017377919861f17b7fe3e133aa597312cad2df012f4 SHA512 017f54ebf56fc59c14ff0e9c2f15b899556ff3d512d22ed2abc35227c079ec64c8eb855f60e65299abd7f8b5433b2268dc7c2e428476efc334e24f0d90181bc8
diff --git a/dev-python/podman/podman-5.2.0.ebuild b/dev-python/podman/podman-5.2.0.ebuild
new file mode 100644
index 000000000000..1d7ad260600f
--- /dev/null
+++ b/dev-python/podman/podman-5.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=podman-py-${PV/_p/.post}
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/
+"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}