summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest2
-rw-r--r--dev-python/poetry/poetry-1.5.1-r1.ebuild (renamed from dev-python/poetry/poetry-1.5.1.ebuild)14
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index bf581597b74d..8c3f3de43396 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,3 +1,3 @@
DIST poetry-1.5.1.tar.gz 1469755 BLAKE2B ac60d6aabe69b1e46a6fbc188579034e716a470384571a611952489d175485cf997636c9206a53e29be073582e672f8010ab5f8f13b58a12dc644279753f903e SHA512 863bc4ea43b6fc5b340f50f007c76d2c253223d6bd55ea5c1ead4bc353c3d4cd85d51372a774276e14d9fca733fac9c2f582892fec950b74f25dc188dafa7a96
-EBUILD poetry-1.5.1.ebuild 3928 BLAKE2B 961203605de46d649decc8dbec26b8ee52571cd569ab0d383f6b371f38897059ec7f20c89d919586e15c8157d0a9c3b29679efe87a05efaadb9b5f404e8dbeec SHA512 d2813f9ba955a8f3d1867b1f2b61cd470706684740fe34ca3b6636a5d02239d2e16c6ca5ee5baf7b417e64054b09974b18c8540557049559ad7a1137cd920664
+EBUILD poetry-1.5.1-r1.ebuild 4157 BLAKE2B a4d6ebc69cdc89c0e7c7e629a85b587cd46e16fa4d4128c59e826c2eef36474cee07215b7ffa0b6ba8c904beb66f5d6f6aa912547518776134f8abff408bf7ec SHA512 5d1702d8453d5cb27e573c4d0064b02abfa398d3e222778805d3e4faedb1b3018a5d6723c997b73b37e0b9ed9caae46ac10d784047e7fa018935bdc9191bf1c4
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-1.5.1.ebuild b/dev-python/poetry/poetry-1.5.1-r1.ebuild
index 9fa3a6a19ab3..272723220fdc 100644
--- a/dev-python/poetry/poetry-1.5.1.ebuild
+++ b/dev-python/poetry/poetry-1.5.1-r1.ebuild
@@ -22,9 +22,12 @@ RDEPEND="
>=dev-python/poetry-core-1.6.1[${PYTHON_USEDEP}]
>=dev-python/poetry-plugin-export-1.4.0[${PYTHON_USEDEP}]
>=dev-python/build-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.12.9[${PYTHON_USEDEP}]
>=dev-python/cleo-2.0.0[${PYTHON_USEDEP}]
>=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
>=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0[${PYTHON_USEDEP}]
>=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
>=dev-python/jsonschema-4.10.0[${PYTHON_USEDEP}]
>=dev-python/keyring-23.9.0[${PYTHON_USEDEP}]
@@ -35,14 +38,16 @@ RDEPEND="
>=dev-python/requests-2.18[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
>=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
>=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
>=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.22.0[${PYTHON_USEDEP}]
- >=dev-python/cachecontrol-0.12.9[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
"
-DEPEND="
+BDEPEND="
test? (
>=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
>=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
@@ -61,6 +66,9 @@ src_prepare() {
sed -e 's:"cachy_file_cache", ::g' \
-i tests/utils/test_cache.py || die
+ # unpin
+ sed -i -e 's:\^:>=:' pyproject.toml || die
+
distutils-r1_src_prepare
}