summaryrefslogtreecommitdiff
path: root/dev-python/polib/polib-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/polib/polib-1.0.4.ebuild')
-rw-r--r--dev-python/polib/polib-1.0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.0.4.ebuild b/dev-python/polib/polib-1.0.4.ebuild
new file mode 100644
index 000000000000..dd0fc2c7f091
--- /dev/null
+++ b/dev-python/polib/polib-1.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="https://www.bitbucket.org/izi/polib/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ emake html
+ fi
+}
+
+python_test() {
+ python tests/tests.py || die
+}
+
+python_install_all() {
+ local DOCS="CHANGELOG README.rst"
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}